Changed permissions for entire HDD...help!

Discussion in 'macOS' started by NYR99, Sep 20, 2010.

  1. NYR99 macrumors 6502a

    Joined:
    Dec 30, 2007
    #1
    Hello,
    For some reason or another, I right clicked on my Macintosh HD icon, chose get info, then changed permission to read & write, and applied it to all enclosed items. Then I restarted my MacBook and it wouldn't boot. It would just hang on the Apple logo boot screen with the spinning thing.

    So I did some research online and saw that I would have to wipe my whole hard drive and start over since I applied read & write to all enclosed items. I put the OSX disk in, and booted to it. Before I went to install a fresh copy of OSX, I tried to repair disk permissions instead. To my delight, it worked. I was able to boot like normal.

    But now I am having some strange problems.
    -When I load Firefox, the bouncing icon will be all jumpy.
    -When I log into Skype, the log in sound will only play halfway.
    -The most weird and major problem is the no setting will save at all. If I add a new bookmark in either Safari or Firefox, then quit and reopen the program, it will not be there. If I change my home page, the setting won't save after I quit out.
    If I remove something from my OSX dock, then log out then log back in, it will be back.

    Any ideas on what I need to do?
     
  2. ToastyX macrumors regular

    Joined:
    Oct 4, 2005
    #2
    Repair permissions doesn't fix the permissions for your home folder, so you won't be able to save anything.

    Open Applications -> Utilities -> Terminal, then copy and paste the following command and press the enter key: sudo chown -R `whoami`:staff ~

    Then type in your password (it won't show anything as you type) and press the enter key. That will change the permissions of everything in your home folder to be owned by you. It might take a while to complete, depending on how much stuff you have in your home folder.

    There may be other permissions that are still messed up as well, but see if that helps.
     
  3. NYR99 thread starter macrumors 6502a

    Joined:
    Dec 30, 2007
    #3
    Thanks for the info. I am actually currently in the process of reinstalling SL (and hopefully preserving all of my content and settings). If that doesn't work I'll give your info a shot.
     
  4. NYR99 thread starter macrumors 6502a

    Joined:
    Dec 30, 2007
    #4
    Whelp, reinstalling SL didn't help. Time to try your method...

    Thank you, ToastyX, it worked!
     

Share This Page