Changed permissions for "Macintosh HD"

Discussion in 'MacBook Pro' started by imagineerthat, Jun 12, 2011.

  1. imagineerthat, Jun 12, 2011
    Last edited: Jun 12, 2011

    imagineerthat macrumors newbie

    Joined:
    Jun 12, 2011
    #1
    For some reason or another, I right clicked on my Macintosh HD icon, chose get info, then changed permission to read & write, and applied it to all enclosed items. Then I restarted my MacBook and it wouldn't boot. It would just hang on the Apple logo boot screen with the spinning thing.

    So I did some research online and saw that I would have to wipe my whole hard drive and start over since I applied read & write to all enclosed items. I put the OSX disk in, and booted to it. Before I went to install a fresh copy of OSX, I tried to repair disk permissions instead. To my delight, it worked. I was able to boot like normal.

    But now I am having some strange problems.
    -When I turn on Macbook a window pops up that says "error system extension cannot be used" and then it says below it:
    The system extension "/System/Library/Extensions/BJUSBLoad.kext" was installed improperly and cannot be used. Please try reinstalling it, or contact the product's vendor for an update.

    -Laptop reboots by itself after screensaver comes on, when I try to log in and load Firefox, the bouncing icon will be all jumpy, firefox never loads.

    I tried running repair disk permissions and it keeps saying "permissions differ on "system/library/frameworks/" then a bunch of codes

    It also says "Warning: SUID file "system/library/coreservices/... has been modified and will not be repaired."

    I have a Macbook Pro with Snow Leopard
    I have no idea what to do. Help :confused:
     
  2. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #2
    You answered it in your 2nd paragraph, just do a wipe and clean install.
     
  3. yusukeaoki macrumors 68030

    yusukeaoki

    Joined:
    Mar 22, 2011
    Location:
    Tokyo, Japan
    #3
    yeah thats what you basically have to do. Clean you Hard drive out
     
  4. 42streetsdown macrumors 6502a

    42streetsdown

    Joined:
    Feb 12, 2011
    Location:
    Gallifrey, 5124
    #4
    it'll be next to impossible to figure out what's wrong. Do a clean install, it'll save you the hassle.
     
  5. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #5
    Sometimes I wish that the OS was a little smarter in allowing people to monkey around with permissions. The *NIX permission scheme is quite contorted and when I was working it was not surprising to see new employees with Comp Sci degrees run amuck changing permissions without knowing what they were doing and resulting in a godawful mess. I have changed permissions on OSx, but I'm very careful to only do it down from the user home directory level.

    Your only real recourse now is to do a clean install.
     
  6. marc11 macrumors 68000

    Joined:
    Mar 30, 2011
    Location:
    NY USA
    #6
    The OS shouldn't replace common sense. Apple, as much as they try cannot protect everyone from everything, sometimes you need to ask yourself "is this a good idea and do I know what will happen"...
     
  7. imagineerthat thread starter macrumors newbie

    Joined:
    Jun 12, 2011
    #7
    What if I just right click on "Macintosh HD" > get info > and change the "privilege" back to read only, as before? BTW: This is not the main account on the macbook, it has administrator privileges but it wouldn't let me update some applications, that's why I tried to change the permissions, because it was beginning to get annoying.
     
  8. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #8
    Why don't you try it out and report back?
     

Share This Page