Changed permissions now Mac wont start

Discussion in 'macOS' started by shoreyduke, Feb 10, 2012.

  1. shoreyduke macrumors newbie

    Joined:
    Feb 10, 2012
    #1
    Please can someone help. I am another victim of stupidity and apple’s bug..
    I changed my permissions, adding myself as read write and including the change to all enclosed folders.
    Now my system just hangs on re-start with the apple logo on grey screen and the turning wheel.
    I have tried booting into single user mode and tried the following strings, but none seems to work.
    I do not know DOS and am quite ignorant when it comes to Command prompt strings and commands but will follow letter by letter any advice.
    Oh .. to make matters worse I am stuck at sea and do not have my startup CD !!! STUPID!!
    I have a MacBook running 10.6


    Boot into single user mode and type
    sudo chmod 755
    The result is
    sudo: / private/etc/sudoers is in mode 0664, should be 0440”
    :/root# sendamail ; warning: valid_hostname:empty hostname
    Sendmail : fatal : unable to use my own hostname

    The other solution I tried, also in single user mode is

    Cd /Volumes
    :Volumes root# chmod 755 Richard\’s\ Notebook/ (this string is achieved by typing the first letters of my drive and TAB)
    The result is just “:Volumes root#”

    I also try
    chmod 755 Richard’s Notebook/ .. result is “>”

    Please help .. I really really need my email..
     
  2. Mac-Michael, Feb 10, 2012
    Last edited: Feb 10, 2012

    Mac-Michael macrumors regular

    Joined:
    Jan 13, 2010
    #2
    Try this:

     
  3. shoreyduke thread starter macrumors newbie

    Joined:
    Feb 10, 2012
    #3
    Thank you for your time Michael. I did exactly (word for word) as you suggested but the return response on the last line was ..
    “-sh: /user/sbin/diskutil: No such file or directory”

    I have been trying this fix ..
    • Boot into single-user mode (boot while holding down CMD-S)
    • Follow the on-screen instructions to mount the file system as read-write (a fsck/mount command followed by a mount command)
    • Type the following: "chmod o+r /" followed by "chmod o+x /"
    • Type "exit" to leave single user mode and complete the boot sequence.
    but cant seem to mount the file system as read-write .. it says it is (hfs, local, read-only, journaled) .. So I presume the commands cant change anything in the system??
     
  4. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #4
    First of all, type "which diskutil" and you should get back /usr/sbin/diskutil. If not, use whatever path really comes back. Second of all, you might have to use something other than "/" as the target to repair permissions. Perhaps something like "/usr/sbin/diskutil repairPermissions /Volumes/Somedisk" where Somedisk is the disk you booted from and are trying to repair. More here...
     
  5. shoreyduke thread starter macrumors newbie

    Joined:
    Feb 10, 2012
    #5
    Thank you rOk..I did as you suggested but could not run disk utility. The error is:"Unable to run because unable to use the DiskManagement framework" and further down "framework being unavailable due to being booted in single-user mode" ..
    What is worrying me is that after changing permissions, I applied to all enclosed items!! That is serious and have read that it is impossible to fix without the installer disks, which are safely locked up at home.... I am in the South China sea and will be stuck here for the next two weeks, without my laptop and email (I am relying on others computers). I will try and explore the links you gave me. Many thanks, your help was greatly appreciated.
     
  6. shoreyduke thread starter macrumors newbie

    Joined:
    Feb 10, 2012
    #6
    Update .. I have found a boot utility called rEFIt "http://refit.sourceforge.net/"
    and have made a boot cd from the image.
    I can boot into rEFIt but I dont know command prompt and cant seem to change directories and find Diskutilities on my HD.
    I am also limited in bandwidth. Not doing very well this end.........
     
  7. Mac-Michael macrumors regular

    Joined:
    Jan 13, 2010
    #7
    There's a discussion on the topic here, but it's from a few years ago. Still, they mention and recommend an utility by the name of AppleJack

    Also, which folder's permissions did you modify, what's the name of it?
     
  8. shoreyduke thread starter macrumors newbie

    Joined:
    Feb 10, 2012
    #8
    Thanks Mac-Michael. I have applejack installed on my drive and when I boot into single-user mode I can run it .. no problems BUT I get the same error from applejack as I do when trying to run Diskutility ....
    "Unable to run because unable to use DiskManagement framework. Common reasons inclde, but are not limited to, the DiskArbitration framework being unavailable due to being booted in single-user mode."

    I changed permissions and included ALL enclosed items.....
     
  9. shoreyduke thread starter macrumors newbie

    Joined:
    Feb 10, 2012
    #9
    Sorry .. In my permissions I had ...
    Users to read only
    Admin to read/write

    I added myself in as an administrator and applied to all enclosed items ...
    It was as easy as that to render myself computer less ..
     
  10. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #10
    Given that you don't have your system disk with you, your options are limited.

    Perhaps a trip to the apple store may be in order
     
  11. shoreyduke thread starter macrumors newbie

    Joined:
    Feb 10, 2012
    #11
    If I were to boot from a 3rd part boot disk such as Data Rescue or Disk Warrior, could I then see my hard drive so to run Disk Utility or could those programmes repair the permissions?
     
  12. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #12
    DiskWarrior supports repairing disk permissions, so you can give that a try if you have access to it. Data Rescue does not, it's designed only to retrieve files and leave the hard drive untouched.

    jW
     
  13. shoreyduke thread starter macrumors newbie

    Joined:
    Feb 10, 2012
    #13
    Thank you Mal .. Oops ...I have just seen the file sizes of the boot dvd ... too big for me to download from here ... Thank you for the advice. I will just keep on trying.
     
  14. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #14
    I have to agree. It sounds like the OP picked / and applied rwxr x r x to his entire Macintosh HDD. On the surface this might seem safe but it's the equivalent of taking a bazooka to Macintosh HDD and the best way to recover would be a wipe and install (provided his data is backed up) :eek:.

    This makes me appreciate why Apple is trying to make OS X more like iOS. Unless you jailbreak, there is no way to make an iPhone useless by applying this sort of blunt force trauma.

    The good news is that OS X is Unix underneath. The bad news is that there are so many permissions to repair, I can't imagine the OP stumbling upon the right combination of permissions from single user mode. To me this would require a "snapshot" of a working Macintosh HD running 10.6 that listed permissions for every folder on the system. It would be something like a recursive "ls -RF / > /allfiles.txt" Of course the users folder should be removed from this file as you don't care about the users' folder on your friend's Mac.

    You could then go through the list, focusing on folders like /bin, /sbin, /Applications, /Library, etc changing permissions on your Mac to look like those in a known good allfiles.txt from a friend's working OS 10.6 Mac.
     
  15. shoreyduke thread starter macrumors newbie

    Joined:
    Feb 10, 2012
    #15
    OH GOSH !!! ... How could such a big mess arise from just one click?
    I am not technical .. but for Apple to allow the loss of an entire computer with just a click of the mouse !!! It would be harder for me to have formatted the drive .. at least there are a few steps involved and a WARNING !!!
    Granted it was my stupidity and ignorance.....
    Thank you all for your help, it was greatly appreciated.
     
  16. waynep macrumors 6502

    Joined:
    Dec 31, 2009
    #16
    Really a single click?

    anyways, how about downloading the Lion Recovery Assistant here: http://support.apple.com/kb/DL1433?viewlocale=en_US&locale=en_US

    I know you are not running Lion, but if you have access to another Mac, you could make a bootable USB thumb drive and boot from it. On it is a Disk Utility, and you can do a repair permissions. . . . Yes you are not running Lion, but maybe it would fix enough permissions to make your machine bootable again, and then run repair permissions from your booted machine????? Just a thought.
     
  17. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #17
    Took more than a single click, messing about in the command shell can cause all sorts of havoc.
     
  18. shoreyduke thread starter macrumors newbie

    Joined:
    Feb 10, 2012
    #18

    It was not through command lines (I do not understand or know the language and have no wish to mess there)...
    All I did was Control Key+i ....
    At the bottom of that window there are users ... I just added myself as Admin (I thought it was OK for me to be Admin) and clicked "apply to enclosed Items .... ??

    ----------

    Thanks waynep .. i checked the link BUT ... "If the computer shipped with Lion, the external recovery drive can only be used with the system that created it."

    His, unfortunately, was shipped with Lion. Many thanks...
     
  19. shoreyduke thread starter macrumors newbie

    Joined:
    Feb 10, 2012
    #19
    Thanks all for your help.
    I have managed to make a boot cd with Lion recovery and am able to start up and run disk utilities. The problem is that Disk Utilities repair permissions is Greyed out.
    I believe this is because Disk util has to run off the reive to be repaired.
    I try cd / to my HD and try and run diskutil repairPermissions / but keep getting errors .. no such file or invalid argument.
    It seems as if mt HD is locked to everything I try.
    Reloading is the only option.
    I also tried to copy my files to a FAT32 formatted drive with no success.

    Another two questions ...

    If I do a re-install and save my previous system AND choose the option to "save user settings and network preferences" .. will that save all the bad permissions? AND ..
    Will I be able to copy my files to my newly installed system....
    If I can do this .. when I do copy are new permissions set on the copied files??
    Does anyone know??
     
  20. dj-katchey macrumors newbie

    Joined:
    Apr 8, 2013
    #20
    I accidentally changed the permissions on a disk

    If the disk in question is your Mac OS X startup disk and your computer stops starting up at the blue screen, restart with the Command and S keys held down, and enter the following commands:

    mount -uw /
    chown root /
    chmod 1775 /
    exit

    Enjoy!!!!
    Works 100%:):apple:
    [/B]
     
  21. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #21
    Repair Permissions only works on a disk with an installed system, if that system has a /Library/Receipts folder. RP is NOT good enough to fix a major hose of permissions across the entire disk.

    You need to reinstall the OS.

    And for the record, don't manually change the permissions recursively. Don't give yourself read-write access to every folder: you are not supposed to have access everywhere. If you need to tinker with system folders, then there are ways of doing that. You'll excuse me if I suggest that your current level of skill is not quite at the point where should need to start interfering with system folders.

    If there is something you particularly want to achieve, ask here, and people can give you some pointers.
     
  22. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #22
    I remember when I was working we had smart-a** new employees who supposedly had CS degrees and knew *NIX forward and backwards and they would come in and monkey around to "make it work better" and wind up with unbootable systems. It certainly deflated their oversize egos.

    When you start monkeying around with permissions, you run down a dangerous road. It is not a bug in OSx.
     
  23. ebernet macrumors newbie

    Joined:
    Apr 5, 2005
    Location:
    Seattle, WA
    #23
    Thank you for saving my (vegan) bacon! I stupidly removed "everyone" access from my boot volume (even though it had read_only, it scared me that "anyone" could read it). Searched everywhere for a solution, and this fixed it instantly. Thank You!!!
     
  24. k0ry, Jul 7, 2014
    Last edited: Jul 7, 2014

    k0ry macrumors newbie

    Joined:
    Jul 7, 2014
    #24
    T*h* A* N*K* Y 0 U !

    my comps been down for a couple days , just found this thread and worked great!





    thank you again ebernet & dj-katchey


    well........ never mind ...... let me in but same stuff when i restarted...............
     
  25. Macsterwoman macrumors newbie

    Joined:
    Oct 23, 2013
    #25
    Thank You!!!!

    I changed my permissions for "everyone" on my hard drive, not knowing the outcome would be my MacBook pro 10.9.5 would be frozen on the grey screen (not bringing up the login page).

    Your advice worked great. I just wanted to take the time to say thank you and that I think you are wonderful. :)
     

Share This Page