Resolved Changed permsissions to users, now osx won't boot. (fsck_hfs)

Discussion in 'macOS' started by eiricorn, Dec 9, 2014.

  1. eiricorn, Dec 9, 2014
    Last edited: Dec 9, 2014

    eiricorn macrumors newbie

    Joined:
    Dec 9, 2014
    #1
    Hi!

    My macbook won't boot up anymore, but instead get stuck on the gray apple screen with the spinning wheel.
    Specifically on executing FSCK_HFS with verbose mode.

    I let fsck_hfs in verbose mode run for a while, but it appears to be stuck on executing. I had it run for almost 9 hours, but it was still stuck. I ran verify permissions and repair, and verify disk and repair through disk utility to no avail. It won't boot up in safemode either. It will however boot up in ubuntu through a USB stick.
    I then ran fsck -fy in single user mode, which told me "The volume Macintosh HD appears to be OK.
    *****The volume was modified *****".
    I ran fsck again three times which now only says "The volume Macintosh HD appears to be OK." Rebooted, but still stuck at fsck_hfs

    Last session I used my macbook, I did numerous things, but there's one thing I did that I think has caused this to happen. I was deleting some junk files such as downloads duplicate files. I didn't know the password to all the users on the computer, so I changed users folders and all files inside to RW to everyone, so I could delete their junk files as well. I didn't delete any system files, only junk that is safe to delete.

    Is this why osx won't boot up? The other things I did on the last session was: install a Photoshop trial, uninstall unused user installed programs, run ccleaner to clear browser cache and stuff like that.

    I read this post: http://forums.macrumors.com/showthread.php?p=17338567#post17338567 which said that chmod ugo+rwx / might help, but I have to reinstall osx afterwards anyway to get the proper permissions the all the files. Sorry for being such a Mac noob.

    Thanks.
     
  2. Alrescha, Dec 9, 2014
    Last edited: Dec 9, 2014

    Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #2
    I do not have any easy answer. /var/log/system.log may have some clues.

    As to changing permissions, next time you might just give yourself a root shell with sudo instead.

    A.

    Addendum: You should of course have a backup, but in general re-installing OS X is non-destructive, so that may be the best solution.
     
  3. eiricorn thread starter macrumors newbie

    Joined:
    Dec 9, 2014
    #3
    Thanks, I will look at the log when I get home. Reinstalling OS X, will keep all user files safe including program files, right? I wish I had a backup, but that's too late now.
     
  4. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #4
    In general, yes. That is not to say there is no risk, your machine is in a funny state.

    You should be able to boot the recovery partition (hold Command-R at boot time) and choose Reinstall OS X, which normally replaces the OS but preserves your data. You do need Internet connectivity. If you have installed some program that needs a specific device driver or kernel extension loaded, you may need to reinstall that program.

    Apple's OS X Recovery page: https://support.apple.com/en-us/HT4718

    You did not mention your OS, Apple has a specific pages for reinstalling each OS. Hopefully needless to say, you are NOT doing an erase and install.

    If you have another Mac, you have a chance to backup your files using Target Disk Mode; both computers need either Firewire or Thunderbolt in common, but it lets you mount your Macbook drive from another (working :) computer.

    A.
     
  5. eiricorn thread starter macrumors newbie

    Joined:
    Dec 9, 2014
    #5
    Thank you. I couldn't access the system.log from ubuntu because of permissions, so I guess we won't find out exactly what was causing this problem.

    The reason I didn't provide which version I was using is because I wasn't quite sure. I know I had mavericks, but I wasn't sure whether I updated to Yosemite or not.

    I reinstalled OS X, and all is well. Doesn't seem to be any loss of data. I checked if the permissions to the user folders were back to normal, but it's still RW to everyone. So if that wasn't the issue, I'm not quite sure what happened. A little afraid it's gonna happen again, but its good to know a reinstall was this easy and effective.

    Thanks a lot for your help :) I very much appreciate it!
     
  6. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #6
    You are very welcome. I am glad everything turned out ok.

    A.
     
  7. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #7
    Ironically, this is pretty much one of the very few times where running "repair permissions" from the recovery partition might have actually resolved a problem.
    This is what repairing the permissions is designed to resolve.
     
  8. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #8
    Possibly. But:

    1) Multiple things were changed, not just permissions.
    2) It is not obvious why changing permissions on user files (not affected by Repair Permissions) would cause the machine to not boot.
    3) Those permissions were not changed by the re-install, so there is an implication that failure to boot was caused by 'something else'.

    It would probably have been harmless to try it, just the same.

    A.
     

Share This Page