Changing decimal separator symbol in Excel

Discussion in 'Mac Apps and Mac App Store' started by PJM, Dec 3, 2007.

  1. PJM macrumors newbie

    Joined:
    Oct 16, 2007
    #1
    I need to use comma (,) as decimal separator instead of point (.) in Excel 2004. I have already tried changing the system settings, but it didn’t work. Does anyone know how to do that? Thanks in advance !!!!
     
  2. Big-TDI-Guy macrumors 68030

    Big-TDI-Guy

    Joined:
    Jan 11, 2007
    #2
    If it's anything like the Windows version - right click on the cell(s) / rows or columns you want to modify, and under "format cells" tab - there should be a tab on "numbers" - somewhere within the "custom" settings should be what you're looking for.

    If you're just trying to change the separators - Tools Menu - Options - International Tab - Separators (uncheck "use system separators - and put in what you'd rather have) then click "ok".

    Again, this is for WINDOWS Office 2003. But I could imagine there is at least a little bit of consistency between the two versions... I kinda hope... If not, I've just wasted 15 minutes of my time, and 2 of yours.
     
  3. akadmon macrumors 68010

    Joined:
    Aug 30, 2006
    Location:
    New England
    #3
    Damn, seems like there is no way to change it the Mac version of Excel:confused: Changing Formats in the International System Pref pane has no effect on Excel.

    If all you need to do is diplay the numbers with the comma separator, I've put together a simple :D formula that will do the trick. The way I have set it up here is to display 2 digist after the comma, but you can easily customize it to suit your needs.

    =FLOOR(A1,1)&","&MID(TEXT(ROUND(A1-FLOOR(A1,1),2),"0.00"),FIND(".",TEXT(ROUND(A1-FLOOR(A1,1),2),"0.00"))+1,2)

    A1 above could be any cell reference
     
  4. kisiro macrumors newbie

    Joined:
    Mar 31, 2010
    #4
    =SUBSTITUTE(cellyouwanttoreferto;".";",")

    could also work as well to change . to ,
     
  5. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #5
    Cool. But the post before yours is nearly 2-1/2 years old.
     
  6. Angyal macrumors newbie

    Joined:
    Jan 31, 2011
    #6
    3 years old and still kickin!

    And I just found this today and it sure helped. So thanks, kisiro, you just saved my night.
     
  7. bidevi macrumors newbie

    Joined:
    Jan 15, 2009
    #7
    This is how you change the delimiter

    On a Mac
    1. System Preferences
    2. Language & Text
    3. Formats
    4. Numbers => Customize
    5. Adjust Decimal/Thousands for Number Separators / Currency Separators
    6. OK
     
  8. Macsimize macrumors newbie

    Joined:
    Jan 16, 2014
    #8
    And again 3 years later ...

    bidevis tipp works perfectly on Excel Mac 2011.

    7. Restart Excel.

    :)
     
  9. PhilBoogie macrumors newbie

    Joined:
    May 15, 2014
    #9
    Without changing any System Settings, entering a period (.) on the numeric keyboard resulted in a comma (,) in Excel 2011. In Excel 2016 this doesn't work anymore and there are no settings in Excel Prefs to alter this behaviour.
     

Share This Page