Changing Default Keyboard

Discussion in 'iOS 9' started by JackieInCo, Apr 18, 2016.

  1. JackieInCo macrumors 601

    Joined:
    Jul 18, 2013
    Location:
    Colorado
    #1
    Yes, another thread about the changing the default keyboard bug.

    I have three iPhones and an iPad that this happens on. I change the default keyboard to be Swype. In most apps, it stays that way and Swype is the default KB. When I try to text someone, the iOS standard keyboard comes up. I change to Swype within the message app and I can type using Swype. I lock my phone and in a few minutes go back and reply to a message and it's the default iOS keyboard again.

    Yes, I do have Swype at the top of the keyboard list and I've even tried putting Swiftly at the top and the same problem happens. It's annoying. Can't seem to find anyone with a fix for this.

    I have my main sim card in an Android phone now because it at least doesn't have this problem.
     
  2. lewy95 macrumors newbie

    lewy95

    Joined:
    Sep 10, 2015
    #2

    When you edit the list of keyboards, delete the default iOS keyboard from the list
     
  3. JackieInCo, Apr 19, 2016
    Last edited: Apr 19, 2016

    JackieInCo thread starter macrumors 601

    Joined:
    Jul 18, 2013
    Location:
    Colorado
    #3
    But then there is no dictation available for texting. I use that sometimes.
    --- Post Merged, Apr 19, 2016 ---
    I seem to have fixed it by deleting the stock keyboard and the adding it back. Swype keyboard stays no matter what I do with a text message. I can switch to the stock and then back to Swype and Swype stays.

    Tried that on two phones with the same result.
     
  4. pacorob macrumors 68000

    pacorob

    Joined:
    Apr 8, 2010
    Location:
    the Netherlands
    #4
    I would advise putting your favorite Swype keyboard first and then Apple's own keyboard in Settings > General > Keyboards. See also the general third party keyboard topic for tips and tricks.
     
  5. JackieInCo thread starter macrumors 601

    Joined:
    Jul 18, 2013
    Location:
    Colorado
    #5
    That was the first thing I tried and it never worked. It was always the first keyboard in the list but the Apple keyboard always showed in text messages instead.
     
  6. pacorob macrumors 68000

    pacorob

    Joined:
    Apr 8, 2010
    Location:
    the Netherlands
    #6
    In which apps? On e.g. the lock screen you can only use Apple's own keyboard for quick replies unfortunately.
    I have no issues whatsover with my third party keyboards in various Apple apps and third party apps. For some apps you will have to allow it first in the app in order to use a third party keyboard.
     
  7. JackieInCo thread starter macrumors 601

    Joined:
    Jul 18, 2013
    Location:
    Colorado
    #7
    This was only happening with the messaging app. As I said above, I fixed it by removing the stock keyboard from the list and then re-adding it. Swype now stays as the default.
     

Share This Page