changing from email with gmail

Discussion in 'iPhone Tips, Help and Troubleshooting' started by snapper07, Feb 28, 2008.

  1. snapper07 macrumors 6502

    snapper07

    Joined:
    Nov 2, 2007
    #1
    I've got my own email address and use it on my iphone and also have it routed through gmail i prefer the way gmail works with the iphone but when i send or reply to mail through the gmail account the from address that the person receives the email from is my gmail account which is not good when I'm sending my business emails!

    Is there any way round this so it looks like it's from my own domain email?
    I have set up the gmail account to send from my domain on the web side of things.

    Thanks in advance
     
  2. sreedy macrumors 6502a

    Joined:
    Feb 24, 2005
    Location:
    Somerset
    #2
    I think you need to make the account you want it sent from as the default account, rather than the gmail one.
     
  3. Robb315 macrumors member

    Joined:
    Feb 8, 2008
    #3
    In the settings under account on gmail where you set up your second account there is the option to reply to emails using the account it was originally sent to or the default account(gmail).
     
  4. snapper07 thread starter macrumors 6502

    snapper07

    Joined:
    Nov 2, 2007
    #4
    hi thanks i've done all that on my gmail account it sends emails that look like there from my name@domainname.com address when on my computer but when i send them from the gmail account on my iphone they still say they are from my name@gmail.com address.

    is there a setting on the iphone i need to change?
     
  5. snapper07 thread starter macrumors 6502

    snapper07

    Joined:
    Nov 2, 2007
    #5
    ive just found this on gmails site

    "Setting custom 'From:' addresses in my mail client
    First, set up the custom address in your Gmail account on the web. Learn how.
    Then just follow the client-specific instructions below:
    iPhone

    Tap Settings > Mail > [your Gmail account] > Address.
    Edit the 'Address' field with your desired email address, and you're done."

    all sounds very simple but when i go back into my gmail account on iphone and it checks for messages i get an error which says.
    " Cannot get mail. The connection to the server "imap.gmail.com" failed"

    Has any one done this and it's work am i missing a trick?
     
  6. saboracuva macrumors newbie

    Joined:
    Dec 12, 2007
    Location:
    Eau claire
    #6
    help

    Please if anyone knows how to fix this let me know to.
    I am having the exact same problem, and i would love to know how to fix it!!!
     
  7. James Hatts macrumors newbie

    Joined:
    Mar 1, 2008
    #7
    I have done this by configuring my Gmail account manually (using the 'other' button and setting my main business email as my outgoing address.
     

Share This Page