Changing Icons Issue

Discussion in 'Jailbreaks and iOS Hacks' started by Mess, Oct 1, 2009.

  1. Mess macrumors 6502

    Mess

    Joined:
    Nov 27, 2008
    Location:
    Newcastle Upon Tyne, UK
    #1
    Hi,

    Sorry if this is posted some where obvious but I have had a search around and cant seem to find an answer.

    I have been changing icons for apps on the iphone and although its all gone smooth i am a littl confused with some icons.
    (im changing them manually as i have removed Winterboard due to lagg)

    Most of the icons look how they should but some of them have a square outline around them with a shaddow. How do i get rid of this? See the image for what i mean.

    Thanks

    Andy
     

    Attached Files:

  2. Mess thread starter macrumors 6502

    Mess

    Joined:
    Nov 27, 2008
    Location:
    Newcastle Upon Tyne, UK
    #2
    can any one help with this?

    I dont think its the icons ive replaced the orginals ones with as they are the same as the others on the screen. All from the Glass Orb theme.

    Any sensable suggestions are welcome.

    Thanks

    Andy
     
  3. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #3
    You are going to have to replace the icon overlay images with blank PNGs.
     
  4. Mess thread starter macrumors 6502

    Mess

    Joined:
    Nov 27, 2008
    Location:
    Newcastle Upon Tyne, UK
    #4
    Thanks but, how do i do that? :confused:

    Any idea where its located?

    Thanks

    Andy
     
  5. siorai macrumors 6502

    Joined:
    Sep 14, 2007
    #5
    That's the gloss added by iTunes for new apps. You can disable it like this:

    From what I remember, it doesn't work retroactively, so for any icons that have it now, you'll have to delete and reinstall those apps. Once you have this added to your theme's info.plist you shouldn't see the gloss added to any new icons.

    edit: Doing this means you don't have to change the overlay pngs as this will cause them to not be applied at all.
     
  6. Mess thread starter macrumors 6502

    Mess

    Joined:
    Nov 27, 2008
    Location:
    Newcastle Upon Tyne, UK
    #6
    Thanks.

    I just tried doing this. Amended the info.plist file in springboard folder, then rebooted phone. removed then re-synced apps then changed icons on a few then rebooted.

    No difference. Still the same Shaddow thing. :(

    What else can it be?
     

Share This Page