Changing keyboard layout

Discussion in 'Mac Basics and Help' started by digitalangel, Nov 8, 2007.

  1. digitalangel macrumors newbie

    Joined:
    Nov 3, 2007
    #1
    My USB keyboard to go with my new mac mini has just arrived in the post.
    Turns out it's the USA layout, with the @ symbol marked as being above the number 2.
    I want to use the British layout where you use the ' key with shift to the @ symbol, i don't mind that it's marked incorrectly on the keys, as long as they type the way i want them to.

    So i went to 'international' in system prefs, to change the input options there... only to find they were already set to british.

    can anyone suggest how to get my keys to swap over?
     
  2. pjac macrumors regular

    Joined:
    Jun 20, 2007
    #2
    Actually, you probably have got your Mac Mini using the "Apple UK Layout" rather than the "IBM/Windows UK Layout". Try SHIFT+3 and see if you get a pound sign etc. And look at photos or a physical UK Apple keyboard if you need more proof. Basically the "Apple British Layout" is very close to their "Apple USA Layout" but with a proper full sized enter key.

    I've got the same problem as you, but with a USB Ergonomic keyboard on a Mac Pro :(

    What's currently really annoying me the the ~, # and \ keys used in programming and command line work (in addition to the "/@ problem).

    Is there a way to tell the Mac to use the "IBM/Windows UK Layout" rather than the "Apple UK Layout"?

    UPDATE: See this thread which may have a solution by downloading a fixed layout. Messy!
     
  3. Avenger23 macrumors regular

    Avenger23

    Joined:
    Dec 28, 2001
    Location:
    Clovis, NM
    #3
    Have you tried using the International System Preferences control panel? You can change the keyboard layout settings there for United Kingdom/British. Also you can turn on the Keyboard Viewer from there to see what the keys are doing when you are trying different key combinations to make sure you have the right layout.

    Also, here is the link to a video on Apple on the Keyboard Viewer/International settings

    http://www.apple.com/business/theater/#tutorial=keyboardviewer

    Hopefully this will help you out there!:)
     
  4. pjac macrumors regular

    Joined:
    Jun 20, 2007
    #4
    Thanks for trying but you've miss-understood. The keyboard IS setup as as British/UK, for example SHIFT+3 = £.

    The trouble is Apple's idea of a UK layout doesn't match the industry standard originally set by IBM.

    i.e. On an Apple UK keyboard, SHIFT+2=@ (just like in the USA)
    On an IBM/Windows UK keyboard. SHIFT+2="

    I want my Apple to understand SHIFT+2=" and all the other keys combinations like # as printed on my keyboard and as I am used to.
     
  5. pjac macrumors regular

    Joined:
    Jun 20, 2007
    #5
    I've just downloaded and installed Phil Gyford’s real British keyboard layout, and it seems to be working fine. Some applications don't like you switching layout and have to be restarted for the change to work.
    http://www.gyford.com/phil/writing/2005/11/20/using_a_british.php

    I've also read the Mac may revert to the default layout in the login prompt (so passwords with symbols in might be trouble).

    This issue would affect most Mac Mini users in the UK, so I don't know why Apple don't include the IBM British layout with the OS. Odd.

    UPDATE: The enter/return keys don't let you rename files in Finder with Phil's layout :(
     
  6. Avenger23 macrumors regular

    Avenger23

    Joined:
    Dec 28, 2001
    Location:
    Clovis, NM
    #6
    Sorry... I misunderstood what you were needing help with. I didn't realize you already had tried the International setup. :eek:
     
  7. Cartroo macrumors newbie

    Joined:
    Aug 20, 2008
    #7
    I found the keyboard layouts from Phil's page didn't work for me. I've no idea whether it's my version of OS X (10.5.4) or my particular keyboard (which is also going through a KVM).

    However, I found a utility called Ukelele which lets you graphically edit your layout, and worked out the correct mapping by trial and error - now it works like a charm!

    In case anybody else is using a British layout windows keyboard, and you have trouble getting all the keys to work, you can try my layout:

    http://www.andy-pearce.com/random/windows-uk.keylayout

    Right-click that link and select "Download linked file as...", and save it to, say, your desktop. Then open your home folder, go into Library, and then Keyboard Layouts, and drag that file in there. Then you'll need to log out and back in again, and you should then find a new entry in the list of keyboard layouts in the International dialogue (under Input Menu) called "windows-uk". Tick that, and then you should be able to select the layout.

    Hope that's helpful for someone!
     

Share This Page