Changing my iPhone's MAC address (problems)

Discussion in 'Jailbreaks and iOS Hacks' started by djearlybird, Aug 14, 2008.

  1. djearlybird macrumors regular

    Joined:
    Jul 3, 2007
    #1
    Hi guys. I tried changing my MAC address today at work for the 1st time in a few months, and now it won't let me do it. I would always type ifconfig en0 lladdr xx.xx.xx.xx.xx.xx and it would change with no problems. However now when I do it it spits the error stating "ifconfig: ioctl (set lladdr): Operation not permitted"

    Anyone have a clue why this is happening? Last time I was able to do it, I was running 1.1.4, but I don't think that should be the problem. Suggestions? :confused:
     
  2. djearlybird thread starter macrumors regular

    Joined:
    Jul 3, 2007
    #2
    I figured it out. You need to login via Terminal 1st as root, not mobile.
     
  3. tkiltkil macrumors newbie

    Joined:
    Jan 3, 2010
    #3
    Title

    Well, how exactly do you do this? How do you change from mobile to root?
     
  4. kAoTiX macrumors 6502

    kAoTiX

    Joined:
    Oct 14, 2008
    Location:
    Midlands, UK
    #4
    Basic linux commands from the terminal on the iPhone.

    su root
    will then prompt for password

    sometimes just 'su' on its own will work but I haven't tried it.
     

Share This Page