Changing permissions on bootcamp partition

Discussion in 'Mac Apps and Mac App Store' started by scotthayes, Sep 11, 2007.

  1. scotthayes macrumors 68000

    scotthayes

    Joined:
    Jun 6, 2007
    Location:
    Birmingham, England
    #1
    Installed bootcamp (no problems) but when I try to access it through WMWare it reports permissions are set to read only. When I check the volume permissions in OS X they are 'read only'

    Any one know how to change them?
     
  2. iChill03 macrumors newbie

    Joined:
    Mar 4, 2008
    #2
    Change Promission on bootcam

    hey dude. i was trying to do this as well and i sort of think that its not possible
    but give it a try
    go to terminal
    cd //
    cd Volumes/
    sudo chmod 777 (name of the bootcam hard drive)
    then it will ask for a password and put in ur main password, the same one you use to update your mac.


    i did
    sudo rm * in my root dir
    and entered my pass. and that deleted everything regardless
    so i think if anything can change the mode of the drive it would be sudo chmod 777. and it didnt work for me i think it because its a diffrent format or something...
    take care...
    also dude. its read only from ur mac as well. so if ur gone play around changing promissions. do it from ur mac cuz ur parallel has the same access as ur mac as default .
     
  3. mongrol macrumors regular

    Joined:
    Jul 16, 2007
    #3
    You can't. Your windows partition (that bootcamp created) will use the NTFS filesystem. Apple does not (and never will) provide write support for NTFS.
     
  4. pricerob macrumors newbie

    Joined:
    Oct 21, 2008
    #4
    you CAN change permissions

    Install MacFUSE and NTFS-3G; this gives you custom permissions for manipulating NTFS volumes. This works on externally mounted NTFS volumes as well as your BootCamp partition.
     
  5. bergui45 macrumors newbie

    bergui45

    Joined:
    Oct 5, 2008
    Location:
    Chambors,Oise,France
    #5
    changing permissions of the Bootcamp NTFS partition

    hi pricerob,

    i tried to use this trick since my Bootcamp NTFS partition is now "read only" and cannot boot anymore...
    The mess went after trying to update //desktop 3 to 4: the upgrade process buggued in the halfway when trying to install the // tools...
    When i tried after to install Macfuse, i was told that a newer release is already installed! When looking for "NTFS-3G" in spotlight i also found it's already here in the same directory! Probably you get this stuff when performing the installation of the version 4 of the new // desktop!

    The installation went flawlessly until end! The mess happened when launching the VM and choosing the bad way with no return: upgrading the virtual machine without saving the previous working VM...
    Please let me know exactly how to fix this mess since i got the "autochk missing" skipping..." after what the boot process collapse!
    Should i be able to put my MBPro in target mode connected thru Firewire to my Wintel XP_SP3 computer i could use chkdsk.exe to clean up my wounded Bootcamp partition!
    Thanx for what kind of strings to enter in terminal...
     

Share This Page