iMac Pro Changing photo icon on iMac pro to external ssd

Discussion in 'iMac' started by Bigdog9586, Feb 25, 2018.

  1. Bigdog9586 macrumors 6502

    Joined:
    Apr 15, 2015
    #1
    got a new iMac pro, first Mac in 10 years so am moving along slowly. I purchased a external 1tb ssd and plugged it in. Created a Pictures album and transferred about 9,000 pictures from my pc to this drive by using a usb and copying/pasting. Now that they are all there I also created a Document folder and did same. Also using drive as backup. My problem is I’ve googled changing so when I click on the photo icon it would go to the external ssd. This is last directions I’ve used. All were similar.
    http://www.idownloadblog.com/2016/02/08/how-to-move-photos-library-to-external-drive/
    What am I missing.
     
  2. h9826790 macrumors G5

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    That looks complicated. Did you try just hold down the Option key to start Photos. And then create / select the Library you want?
     
  3. Bigdog9586 thread starter macrumors 6502

    Joined:
    Apr 15, 2015
    #3
    doesn't work. Says I don't have permission to do this.
     
  4. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    What format/partition map is used on your external drive? GUID? Master Boot Record?

    If you transferred photos from your PC, and now the drive can't be modified from the iMac, it's likely that your drive is formatted NTFS, which the Mac, with macOS, cannot modify natively.
     
  5. Bigdog9586 thread starter macrumors 6502

    Joined:
    Apr 15, 2015
    #5
    Its Mac OS Extended (Journaled). I plugged it right in my iMac and it saw it right away. PC wouldn't see it. So I used thumb drive and loaded picture folders onto it and on a Pictures folder I created on the External SSD I copied the folders with Pictures on it over. I can click on the drive and see, move, delete whatever with them but I just can't get the iMac to change over the default Photo Album to this external drive.
     
  6. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    Get Info on your external drive.
    Make sure the box "Ignore ownership on this volume" is checked.
    When I make permissions/owner changes on a drive, I will usually eject, then remount that drive.
    Also, try restarting the Mac. You should not need to do a restart, but it's one more thing to try...
    And, then try the Option-launch Photos.
     
  7. Bigdog9586 thread starter macrumors 6502

    Joined:
    Apr 15, 2015
    #7
    I found the get info button. But nowhere on it can I find the ignore ownership. I even unplugged drive, shut off computer, restarted and plugged in the drive. Did info which says a lot but not ignore anywhere.
     
  8. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    Do you see "Sharing & Permissions" at the bottom of that Info window?
    That section should show that you "can read & write" to the volume.
    The "ignore" box is at the bottom of that section. You have to click the little padlock to unlock that section so you can make changes.
     
  9. Bigdog9586 thread starter macrumors 6502

    Joined:
    Apr 15, 2015
    #9
    --- Post Merged, Feb 26, 2018 ---
    Didn’t see any of it.
     

    Attached Files:

  10. CoastalOR macrumors 68020

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #10
    OP:
    Could you verify and show your partition map on the Glyph external (use the Disk Utility app in the Applications/Utilities folder)?
     
  11. Bigdog9586 thread starter macrumors 6502

    Joined:
    Apr 15, 2015
  12. FredT2 macrumors 6502a

    Joined:
    Mar 18, 2009
    #12
    Try changing "Everyone" to Read/Write.
     
  13. Clix Pix macrumors demi-goddess

    Clix Pix

    Joined:
    Oct 9, 2005
    Location:
    8 miles from the Apple Store at Tysons (VA)
    #13
    In Disk Utility, click on "Atom Media" (the entire drive) rather than "Glyph 1TB" and that is where you will see if "GUID Partition Map" is specified......
     
  14. Bigdog9586 thread starter macrumors 6502

    Joined:
    Apr 15, 2015
    #14
    Screen Shot 2018-02-26 at 4.11.21 PM.png
    --- Post Merged, Feb 26, 2018 ---
    Screen Shot 2018-02-26 at 4.14.29 PM.png

    This shows that when I click on the photo icon it is going to that drive but when I open it, its empty.
     
  15. Clix Pix macrumors demi-goddess

    Clix Pix

    Joined:
    Oct 9, 2005
    Location:
    8 miles from the Apple Store at Tysons (VA)
    #15
    What I meant was, do as you did with the first screenshot in post #11 that you showed us earlier -- screenshot of the main Disk Utility screen where all the tabs and options for making changes are.
     
  16. Bigdog9586 thread starter macrumors 6502

    Joined:
    Apr 15, 2015
    #16
    Screen Shot 2018-02-26 at 4.17.19 PM.png

    It shows the photo lib 2 icon inside the Photo folder on the external drive. I have about 25+ folders full of pictures but when I click on the photo icon it shows empty.
    --- Post Merged, Feb 26, 2018 ---
    Screen Shot 2018-02-26 at 4.19.47 PM.png
     
  17. CoastalOR macrumors 68020

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #17
    Launch Disk Utility, select the top level drive (in this case Atom) to see the Partition Map.

    Here is an example:

    Disk Utility PM.jpg
     
  18. Clix Pix macrumors demi-goddess

    Clix Pix

    Joined:
    Oct 9, 2005
    Location:
    8 miles from the Apple Store at Tysons (VA)
    #18
    Thank you, CoastalOR -- for some reason I couldn't seem to clearly express what I was trying to suggest to the OP. Should've done what you did and used a screenshot to illustrate!
     
  19. DeltaMac, Feb 26, 2018
    Last edited: Feb 26, 2018

    DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #19
    If you don't have a folder of photos that is set up for Photos, then nothing will appear when you try to use that folder, until you import those photos into the Photos library.

    And, you won't be allowed to do THAT, until permissions are sorted out on that drive.
     
  20. Bigdog9586 thread starter macrumors 6502

    Joined:
    Apr 15, 2015
    #20
    Screen Shot 2018-02-26 at 4.30.41 PM.png
    --- Post Merged, Feb 26, 2018 ---
    I did have pictures in the folder before but now it shows the external drive which has over 9K pictures in many folders but it shows empty. See post 16
     
  21. Clix Pix macrumors demi-goddess

    Clix Pix

    Joined:
    Oct 9, 2005
    Location:
    8 miles from the Apple Store at Tysons (VA)
    #21
    OK, thanks! Well, that rules out the possibility that the device was not using GUID Partition Map, which is what I had thought might be an issue.
     
  22. CoastalOR macrumors 68020

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #22
    OP;
    It's good that you have a GUID Partition Map and not Master Boot Record.

    Have you selected the Glyph volume as a Time Machine backup disk in the Time Machine System Preference?
     
  23. Bigdog9586 thread starter macrumors 6502

    Joined:
    Apr 15, 2015
    #23
    Yes I have.
     
  24. CoastalOR macrumors 68020

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #24
    Ah ha, that is why you do not have a "Ignore Ownership" check box when you Get Info on the Glyph volume.
     
  25. Bigdog9586 thread starter macrumors 6502

    Joined:
    Apr 15, 2015
    #25
    so if I want to use it for a backup Im out of luck? Its no ig deal as Im using it mostly to save pictures to. I have never shown them when they were on my PC as I also keep them on my phone and iPad. I show them on TV with Apple TV and my iPad.
     

Share This Page

26 February 25, 2018