ditzy

macrumors 68000
Original poster
Sep 28, 2007
1,718
175
Is there a way to change the settings that it uses UK English instead of US English.
Thanks
 

xUKHCx

Administrator emeritus
Jan 15, 2006
12,583
7
The Kop
Open up TextEdit or Safari

Then Edit - Spelling and Grammar - Show Spelling and in the box at the bottom select British English
 
Comment

hughvane

macrumors 6502
Aug 25, 2008
460
0
Banks Peninsula, New Zealand
Open up TextEdit or Safari

Then Edit - Spelling and Grammar - Show Spelling and in the box at the bottom select British English

And in Firefox: Prefs > Advanced > General > Languages > Choose > English [en]

Still has problems with some Br spelling though eg. recognise vs reconize. Just tell FFox to learn the word by adding it to the dictionary (R-click the word).
 
Comment

xUKHCx

Administrator emeritus
Jan 15, 2006
12,583
7
The Kop
And in Firefox: Prefs > Advanced > General > Languages > Choose > English [en]

Still has problems with some Br spelling though eg. recognise vs reconize. Just tell FFox to learn the word by adding it to the dictionary (R-click the word).

With my version of FF (3.0.2) It is under Prefs > Content > Languages

The way I described orginially should be system wide with those applications that use the dictionary but as you have shown that there are some applications that need their own settings adjusted.
 
Comment

ditzy

macrumors 68000
Original poster
Sep 28, 2007
1,718
175
Thanks so much this it's been bugging me for ages.:)
 
Comment

james88

macrumors newbie
Jan 21, 2010
1
0
iWork

Open up TextEdit or Safari

Then Edit - Spelling and Grammar - Show Spelling and in the box at the bottom select British English

how do we change spelling settings to English UK for pages, numbers and keynote? :confused:
 
Comment

PeggyD

macrumors 6502a
Jan 9, 2007
637
2
Covington, WA, USA
how do we change spelling settings to English UK for pages, numbers and keynote? :confused:

Do you have British English set as the default language for OS X? Go to System Preferences > International & drag British English to the top of the list.

I Pages you can change the language for any paragraph style using the text inspector > more & changing the language in the drop-down menu. I don't find an option for changing the language in Numbers & Keynote.
 
Comment

toogoodius

macrumors member
Apr 30, 2010
47
0
British English... DESPERATION KICKS IN!!

Dear all,

it seems that to make my Mac speak British English I should have it set as 'British English' in the list of languages under 'International' in the 'Personal' section of the system preferences.

But my Mac does not have an option for 'British English' and only has 'English'. Please somebody help me before I throw the stupid machine at the wall!

I am using a Macbook and I have the Leopard OS.

As I say, I want the system to speak British and not to have to set every individual program...

cheers!
 
Comment

william1949

macrumors member
Apr 16, 2003
34
0
Victoria, BC
Dear all,

it seems that to make my Mac speak British English I should have it set as 'British English' in the list of languages under 'International' in the 'Personal' section of the system preferences.

But my Mac does not have an option for 'British English' and only has 'English'. Please somebody help me before I throw the stupid machine at the wall!

I am using a Macbook and I have the Leopard OS.

As I say, I want the system to speak British and not to have to set every individual program...

cheers!

Go to "Language & Text" in System Preferences - click on Edit List - I think you will find that British English is not check and that is why it is not showing up.
 
Comment

toogoodius

macrumors member
Apr 30, 2010
47
0
Still no joy

Hey William

thanks for replying. But I'm still having no luck. I do not have "Language & Text" in my System Preferences!

I have an option for 'International'. Language is there (but not text) and there is only 'English' and not 'British English'.

I have taken a screenshot and I hope you can see it ok.

Any more ideas will be gratefully received.

cheers
colin

http://www.facebook.com/home.php?#!/photo.php?pid=5296007&id=607560907[/IMG]
 
Comment

xUKHCx

Administrator emeritus
Jan 15, 2006
12,583
7
The Kop
Press "edit list" and it will bring up a list of all available languages.

Then find British English and mark the checkbox next to that. Then British English will appear in the main list there. Then drag it to the top. You should then log out and then back in again.
 
Comment

toogoodius

macrumors member
Apr 30, 2010
47
0
Brilliant, thanks!

Hey xUKHCx

Thanks very much for that. I have no idea why I couldn't work that out for myself!! I just was NOT seeing it and it was driving me bonkers...

thanks again
colin
 
Comment

xUKHCx

Administrator emeritus
Jan 15, 2006
12,583
7
The Kop
Sometimes it is easy to miss the most obvious things. Glad that you asked the questions and found answers.

Welcome to the forum and feel free to ask as many questions as you want. :)
 
Comment

Rhalliwell1

macrumors 6502a
May 22, 2008
588
1
British English as in English English as in English isn't even in the list as default? Disappointing Apple.
 
Comment

xUKHCx

Administrator emeritus
Jan 15, 2006
12,583
7
The Kop
British English as in English English as in English isn't even in the list as default? Disappointing Apple.

Not sure if it is in the list by default in Snow Leopard but when setting up an install it checks timezones and knows the approximate location of your mac assuming it is online (if not you tell it what area you are in) it should then set the language to the national language of that country. I have long thought this was ridiculous as many people have problems with this and it really should be just one of those things that happen for you. I have sent feedback about this many times but I imagine it is low on the list.

Ho hum.
 
Comment

toogoodius

macrumors member
Apr 30, 2010
47
0
Yes, I agree that it's a bit strange to have to mess about with the settings to get 'British' English. Thankfully I'm sorted now but I did find it frustrating...

Actually I think it seems a very odd thing not to fix, esp if it is a common complaint, as it's a major problem if doing serious/ academic sort of writing. Do Apple not realise that it REALLY pi**es off British people?!

But thanks again for the help I received through this forum
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.