changing the default font in Preview

Discussion in 'Mac Apps and Mac App Store' started by owenswb, May 23, 2009.

  1. owenswb macrumors newbie

    Joined:
    May 23, 2009
    #1
    When I open a PDF file in Preview, the font is, for lack of a better word, weird. I think it's Wingdings or something--in any event, the letters have curls and dots and generally are hard to read. Is there any way to change the default font for PDF files opening in Preview to something more readable, like Times New Roman? Thanks.
     
  2. MAC-PRO-DEMON macrumors 6502a

    MAC-PRO-DEMON

    Joined:
    Jul 10, 2008
    Location:
    Up north in Yorkshire :)
    #2
    Must be a corrupt copy of Preview... try deleting the PLIST from your mac and then restarting the app... That might work...
     
  3. telecomm macrumors 65816

    telecomm

    Joined:
    Nov 30, 2003
    Location:
    Rome
    #3
    Fonts are generally embedded in PDF files, so if you're seeing weird fonts, that's probably the font that was used to create the document.
     
  4. owenswb thread starter macrumors newbie

    Joined:
    May 23, 2009
    #4
    It's not the font used, because if I open it on my Windows machine at work, it looks right. I'll try deleting the PLIST--any hints as to how I actually do it? I don't think the specific program is corrupted, since I have the same problem on my iMac and Macbook, which were purchased about three months apart.
     
  5. telecomm macrumors 65816

    telecomm

    Joined:
    Nov 30, 2003
    Location:
    Rome
    #5
    Do you know how the PDF was created? It's possible to create PDFs without embedding the fonts (which is a bad way to create them), and then I'd guess you might run into a problem like the one you're seeing.

    Anyway, if you're seeing this on more than one computer, it's probably not the preferences file. (Which would be in youruser/library/preferences/, it's the file com.apple.Preview.plist).

    FYI, deleting plist files is sort of an application troubleshooting step 1, since you generally don't lose any settings by doing that (but before deleting it, just move it to the trash just in case), and applications will regenerate a plist file when they start if they don't find one present.
     
  6. jaysquare macrumors newbie

    Joined:
    Jun 8, 2009
    #6
    is your problem solved? if so, how? i got the same issue here too.

    @telecom
    i tried that, but it is still the same. if im not wrong, the displayed font is 'ugly face'. why this font is replacing the normal fonts when viewing pdf files with preview. sigh
     
  7. Guzzie macrumors newbie

    Joined:
    Sep 22, 2008
    #7
    I had issues with this because I had copied all of my fonts over from my old windows machine and as a result I had many duplicate fonts (some of which were corrupt).

    Go to font book, select all (command + A), and run the font validation tool ( File > Validate Fonts). Remove those with warnings and errors. You can also use the Edit > Resolve Duplicates menu option in conjunction with the font validation.
     
  8. julienvancampen macrumors newbie

    Joined:
    Jun 14, 2009
    #8
    Hi, it seems I have similar issues since I have gotten my MBP back from repairs. Like with many 2007 models (as I understood) my videocard gave up on me. Now however, all fonts look really weird in PDF files that previously looked fine. So it can't be the PDF's (they didn't change) nor my version of preview. Anyone any clue of what replacing the videocard might have done to my settings and how I can change it back? This is just very frustrating. Thanks.
     
  9. telecomm macrumors 65816

    telecomm

    Joined:
    Nov 30, 2003
    Location:
    Rome
    #9
    Maybe have a look at the settings in System Preferences>Appearance. (The bottom two options about font smoothing.) Mine is set at (the default) Automatic - best for main display, and is turned off for fonts size 4 and smaller.

    Other that that, I'd check to see how those PDFs look in Adobe Reader.
     

Share This Page