changing the '@' keyboard layout ?

Discussion in 'macOS' started by stuartrozier, Sep 1, 2014.

  1. stuartrozier macrumors regular

    Joined:
    Nov 12, 2011
    #1
    Hello,

    I'm using a Microsoft keyboard, but ... because of the layout, the '@' key isn't where it should be on the keyboard.

    I have round found where it is, but I want to move it, relocate it - map it differently.

    downloading the Microsoft software on the mac doesn't allow me to do this,

    is thier another way of remapping just one key ?

    many thanks
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Sure.... go to System Preferences in the Keyboard pane and in this screen just enter what you want to do. You can say when I press X have Y appear for example.

    [​IMG]
     
  3. stuartrozier thread starter macrumors regular

    Joined:
    Nov 12, 2011
    #3
    thanks for reply -
    that's cool, glad thiers a way around it -
    so if I want to press the 'shift' AND '2' ... will it allow for two button being pressed simultaneously ?
     
  4. illusionx macrumors 6502

    Joined:
    Jul 4, 2014
    Location:
    Brossard, QC
    #4
    What kinda layout do you have on your keyboard?

    Sorry I'm just curious
     
  5. stuartrozier thread starter macrumors regular

    Joined:
    Nov 12, 2011
    #5
    yeah it's Microsoft laser one ...
    but when connecting to mac, it changes layout of some of the keys :/
     
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    Well I gave you a bum idea. I just tested and it only accepts two characters as the input on the left side, so I don't think it will do what you want. You are going to need a third party keyboard remapped like this.

    Sorry for the bad info. :eek:
     
  7. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #7
    It seems odd to me that the keyboard would suddenly change its layout just because it's connected to a Mac. Double-check that you have the right layout selected in the keyboard preferences in the first place.

    You haven't listed your country but you did mention Shift-2, if that's not displaying an @ then try ensuring that you have the US layout selected.
     
  8. stuartrozier thread starter macrumors regular

    Joined:
    Nov 12, 2011
    #8
    thanks for reply...

    so basically i have a Microsoft laser 7000 keyboard for my mini.

    im in the uk, and I'm sure its the uk version selected.

    but on my keyboard, when i want the '@' symbol, which is located above my right shift button, ... when i press it, it displays this ... " (quotation symbol)

    but when i press the quotation symbol, which is my number 2 button, it does the '@' symbol ....

    worry this must all sound really confusing ...

    but basically its just these 2 buttons that are switched round, and isn't a MAJOR prob, but is very irritating ha
     
  9. stuartrozier thread starter macrumors regular

    Joined:
    Nov 12, 2011
    #9
    Result

    used the prefpane, keyboard ... selected the 'british pc' input ?

    so far so good :)
     
  10. Menel macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #10
    My Logtiech is normal when connected to my mac, Shift+2 is still @.

    This is very odd... Very standard keys.

    What does Shift+2 give you on the MS keyboard...?

    ----------

    ah, nevermind. Yay you fixed.
     
  11. stuartrozier thread starter macrumors regular

    Joined:
    Nov 12, 2011
    #11
    ... thanks for reply, so on my kb, shift+2 is the quotation symbol ...
     
  12. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #12
    Aha! Good to hear that you sorted it out; I forgot that the UK uses a funny layout :)
     

Share This Page