Changing the Primary SMTP Server in iCloud on iOS 5

Discussion in 'iOS 5 and earlier' started by monkeygadge, Oct 13, 2011.

  1. monkeygadge macrumors newbie

    Joined:
    Jul 13, 2008
    Location:
    Scotland
    #1
    I can't get the iCloud server to switch off. The switch is there, but it won't do it.

    Settings>iCloud>Account>Advanced(Mail)>Outgoing Mail Server (SMTP) >Primary Server (iCloud SMTP Server>

    Anyone got any ideas?

    I need to do this because I use my own domain for my email address. I currently have myname@myname.com forwarding to my me.com address, then previously in MobileMe I send mail out through a Gmail server. The server settings are still in the outgoing server list in iOS 5, but it's not being used as the iCloud server is the 'Primary Server'' and takes priority over any other server.
     
  2. Hello... macrumors 6502a

    Hello...

    Joined:
    Oct 10, 2011
    #2
    Having that problem too..
    Just added a stmp to the list.
     
  3. monkeygadge thread starter macrumors newbie

    Joined:
    Jul 13, 2008
    Location:
    Scotland
    #3
    Did you manage to turn off the iCloud Outgoing Server?
     
  4. Tom359 macrumors regular

    Joined:
    Jul 13, 2007
    #4
    Exact issue here

    Been forwarding gmail to my .me address for years to have the push feature. I've always been able to turn off all smtp servers except for gmail, so it look like it came from my gmail account. I can do this on my Mac no problem, but I can't turn off the iClould smtp server on either my iPad or iPhone. Surely this is just a bug.
     
  5. ezatech macrumors newbie

    Joined:
    Oct 1, 2011
    #5
    I'm having the same issue. I want to forward on mail from all email addresses i've ever owned into my gmail account, which forwards to the new @me account (just because of its features). And just use the @me account for delivery, but make it look like it's coming from gmail ;)

    Maybe they have disabled it because they don't want others STMPs?
     
  6. Dupolis macrumors newbie

    Joined:
    Oct 14, 2011
    #6
    This needs to change! Our company all uses iphones and we need to use our own smtp so we can send email from ourcompanydomain.com.. BAD feature to just accidentslly lose apple!
     
  7. darkslide29, Oct 18, 2011
    Last edited: Oct 18, 2011

    darkslide29 macrumors 65816

    Joined:
    Oct 5, 2011
    Location:
    San Francisco, California
    #7
    Did you ever get this figured out? Having the same problem. Or are we waiting for iOS 5.0.1.... Thanks.

    Edit: Well, this is a little disappointing.

    After moving to iCloud, the following webmail features will no longer work:
    -Checking external POP email accounts.
    -Using a "Send From" address to send from a non @me.com or @mac.com email address.

    http://support.apple.com/kb/HT4918
     
  8. iceterminal macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #8
    I don't even have the Advanced option at all.
    If I go to Settings-iCloud-Account this is all I get
    [​IMG]

    I'm wondering why I don't have iCloud email account in the Mail app at all.
     
  9. iceterminal macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #9
    Ok, I disabled the mail sync and restarted the phone. Then turned the sync for icloud mail back on.
    Then the account, and advanced options were there. But it wiped out all my other accounts.
    Nice huh?
     
  10. Tom359 macrumors regular

    Joined:
    Jul 13, 2007
    #10
    Here's a fix that works until Apple fixes this:

    -Go into Settings, Mail, Add Account
    -Create a new account...don't pick any of the pre-named ones. Pick "other"
    -click "add mail account"
    From here, enter the information from your iCloud account. My incoming mail server was listed as p02-imap.mail.me.com

    On the bottom of the screen you will see an area for an outgoing SMTP server. Enter the gmail info here. Once it validates, go back and disable mail on your original iCloud account.

    Works perfectly for me. I get everything pushed to me by iCloud, but my replies look like they came from gmail, just like I had it set up with MobileMe.
     
  11. Kilgary macrumors newbie

    Joined:
    Oct 18, 2011
    #11
    THANKS! I just registered for iCloud and had a big regret when I couldn't figure this out. Now I'm once again sending from Gmail and receiving emails at Push speed. Much appreciated!
     
  12. brucku macrumors regular

    Joined:
    Jun 19, 2003
    #12
    one feature missing after doing this: the new "use archive instead of delete button" functionality that they beautifully gave us for ios5.

    ----------

    yes this solves the issue except it loses the "Archive" feature that iOS 5 beautifully gave us.
     
  13. Tom359 macrumors regular

    Joined:
    Jul 13, 2007
    #13
    Yeah, it's not perfect....

    I think that this is clearly a bug that will get fixed. At least until then, we can use our email like we are used to.
     
  14. monkeygadge thread starter macrumors newbie

    Joined:
    Jul 13, 2008
    Location:
    Scotland
    #14
    Tom, you're a MF genius. This is the fix for iOS. Thanks mate.


     
  15. phenixdragon macrumors regular

    Joined:
    Jun 24, 2009
    #15
    I can't authenticate. Many others can't either by doing this. Seem to be hit or miss if you can get it to work.
     
  16. jalman11 macrumors member

    Joined:
    Apr 1, 2009
    #16
    I did this, but I couldn't get a response from p02-imap.mail.me.com, so I just used mail.me.com.

    However, in my settings, I see the only Fetch and Manual are available. So how are you seeing push? Do I need to use the p02 thing? If so, how do I find out what my incoming mail server is listed as...?

    Thx!
     
  17. iPhone Addict macrumors 6502

    Joined:
    Jun 18, 2009
    Location:
    San Francisco, CA
    #17
    Thank you for writing this up. I have a question:

    When you say "From here, enter the information from your iCloud account. My incoming mail server was listed as p02-imap.mail.me.com",

    where do you find this specific iCloud account information? In my iCloud I only see the option of seeing the SMTP server. I don't see any incoming mail server. Could you provide a step-by-step to get to this setting? Thank you!
     
  18. monkeygadge thread starter macrumors newbie

    Joined:
    Jul 13, 2008
    Location:
    Scotland
    #18
    I got the server address 'pxx-imap.mail.me.com' - where xx is the number of your server - from Mail settings in Lion after the migration from MobileMe. I don't know where else you would get this information....you could look into adding iCloud to a PC/outlook etc? That might give you a server address?
     
  19. brucku macrumors regular

    Joined:
    Jun 19, 2003
    #19
    This is the Problem with this method no push. And switching back to google exchange sync it is not as seamless as iCloud and mobile me are/were. We still desperately need a solution to this actual Problem.

    - poor or no push
    - no drafts syncing (if u use google sync and apple mail)
    - no archive button (if u used iCloud iMap or gmail iMap)
    - terrible "replied/forwarded" indicator performance across iOS/mail if you use either gmail connection method

    This is all a mess because apple forced that damn primary server on us. Wonder if we could jailbreak and edit th hosts file so smtp.me.com points to smtp.gmail.com
     
  20. ohio.emt macrumors 6502a

    Joined:
    Jul 18, 2008
    Location:
    Ohio
    #20
    Couldn't you just add your gmail account to your iphone, and use it to send mail but still have your mail pushed using icloud.
     
  21. brucku macrumors regular

    Joined:
    Jun 19, 2003
    #21
    Well not unless apple allows for a true "default sending" setting. Right now it only holds for new composition- not replies so the moment u write back to an iCloud pushed email- it comes from @me. Unless of course you use the iMap/other work around but that is not perfect.
     
  22. ohio.emt macrumors 6502a

    Joined:
    Jul 18, 2008
    Location:
    Ohio
    #22
    But for now in your replies couldn't you just click the where the addresses are then change the from to your gmail. I know it's a pain but still a little better then the imap work around IMO.
     
  23. brucku macrumors regular

    Joined:
    Jun 19, 2003
    #23
    I run my own business, and probably reply to 100+ emails over the course of one day. Also all done on the road from ios on iPhone or iPad. This One extra step would change my day quite a bit.

    I have to say iCloud over custom iMap is the best so far but true iCloud with modified outgoing would be nice to have back.
     
  24. ohio.emt macrumors 6502a

    Joined:
    Jul 18, 2008
    Location:
    Ohio
    #24
    I could see that extra step being troublesome replying to over 100 e-mails.
     
  25. brucku macrumors regular

    Joined:
    Jun 19, 2003
    #25
    And then I get back to my office and my inbox items that should be marked (and hot linked to each of my replies) don't Work- its been a pretty frustrating week.
     

Share This Page