Characters delete when I paste, please help

Discussion in 'Mac Basics and Help' started by snerkler, Aug 19, 2013.

  1. snerkler macrumors 6502a

    Joined:
    Feb 14, 2012
    #1
    Hi,

    If I paste onto anything such as forums, word documents etc it always deletes an existing character, ie one that's already on the page, not one I'm pasting. Sometimes it can be the character in front of what I have pasted, sometimes the one after. Why is this happening, and how do I stop it?

    Cheers

    P.S. Early 2012 15" MBP (non retina) running OS X Mountain Lion
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Are the characters selected (highlighted) when you paste?

    Is it the same application, i.e., safari? Do other apps behave the same way?
     
  3. snerkler thread starter macrumors 6502a

    Joined:
    Feb 14, 2012
    #3
    The characters aren't highlighted initially, but since you brought this up I've run a few tests and it appears that as soon as I 'right click' to paste it does highlight the previous character. It does this when replying to forums such as this (I use chrome), and have also just tried it in notes and the same occurred. Contrary to my first post it doesn't appear to do this with word.

    I have noticed that if it's a character such as a hyphen or bracket it just highlights this character, but if it's a word it highlights the whole word, unless I put a space after in which it just highlights the space. If I've pressed enter to start a new line when I paste it 'removes' that enter so the pasted info goes on the line above :confused:
     

Share This Page