iPod touch "Charging is not supported with this accessory"

NoVertigo

macrumors newbie
Original poster
Jan 16, 2012
3
0
Ok recently I received this message from my Itouch 4th gen. "Charging is not supported with this accessory". However I know for a clear fact it is not the accessory that is the problem, it is the ipod.
Im using the white usb cable that came with it. Ive tried 3 different apple usb chargers, tried another computer and a wall charger, but all it shows is that the ipod is connected but it is not charging.

Ive read countless forums and questions and I can not see a single person getting this problem resolved, and we all know Apples "support" is not support at all. So I was hoping if anyone has any ideas or had this problem and had this resolved, and also how they resolved it.
 

Intell

macrumors P6
Jan 24, 2010
18,901
416
Inside
If you're using a USB charger and it's still showing this error, then the problem is likely a hardware issue with the iPod.
 

Macman45

macrumors G5
Jul 29, 2011
13,198
133
Somewhere Back In The Long Ago
I've had this with a third party HDMI cable on my iPad. The first couple of times I connected it I got the same message about compatibility.

Unplugging and re plugging a couple of times did the trick. You don't say what the accessory is and if it's Apple or another manufacturer?
 

NoVertigo

macrumors newbie
Original poster
Jan 16, 2012
3
0
I have 3 different apple usb cables like I said at top. This is not jailbroken, there are no third party accessories. What I did try doing is backing up and attempting to restore. But The ipod will not stay connected during the process so it wont restore.
 

miss.manson

macrumors 6502a
Dec 12, 2011
764
30
Georgia
I have 3 different apple usb cables like I said at top. This is not jailbroken, there are no third party accessories. What I did try doing is backing up and attempting to restore. But The ipod will not stay connected during the process so it wont restore.
Yep, sounds like a hardware issue.
 

NoVertigo

macrumors newbie
Original poster
Jan 16, 2012
3
0
Thanks everyone, one more question, would anyone have an idea how much it would cost to repair it? It is only one year old, 4th gen.
 

Plutonius

macrumors G3
Feb 22, 2003
8,683
7,806
New Hampshire, USA
You might have lint or something caught in your iPod connecter preventing a good connection. I periodically have to clean out the connector in my iPod to use it in my car. A small pin and some canned air work very well.
 

vinify

macrumors newbie
Aug 4, 2012
1
0
Idyllwild
Charging is not supported with this accessory - persistent

OK, so I have been suffering with this problem for a long time. iPhone 4, iOS 5.1.1 - car charger, three charge cubes and cables later, still the same problem. It starts to charge, then "bleeps" and i get "Charging is not supported with this accessory"

I went to the Apple Store, the tech told me to complete restore and NOT restore. Did that. Before I could activate, I got the "can't charge" message again.

I was advised no ability to downgrade. His only explanation was "some apps have bugs that can cause this. We recommend you wipe clean, re-install app by app and do all of your email account setups. Do not use icloud, or your backup on your PC to restore. All from scratch."

Darn! still does the same thing. It is a true hastle to get to a point of over 50% charge so i can try to make it through the day.

I have tried the "airplane mode" thing and all of the other recommendations listed.

I am now convinced it is NOT hardware or physical connection, rather it is an OS bug. Are there any jail-break work-arounds or whatever? I still have my old Motorola RAZR flip i can use as a backup but what a bother!!!

Please any suggestions?
 

dontwalkhand

macrumors 603
Jul 5, 2007
5,436
1,554
Phoenix, AZ
Have you tried cleaning the dock connector? I had this happen on my iPhones but a can of compressed air to the dock connector fixed the issue right up. Be careful when spraying it though.
 

micoric

macrumors newbie
Aug 22, 2012
2
0
Ok recently I received this message from my Itouch 4th gen. "Charging is not supported with this accessory". However I know for a clear fact it is not the accessory that is the problem, it is the ipod.
Im using the white usb cable that came with it. Ive tried 3 different apple usb chargers, tried another computer and a wall charger, but all it shows is that the ipod is connected but it is not charging.

Ive read countless forums and questions and I can not see a single person getting this problem resolved, and we all know Apples "support" is not support at all. So I was hoping if anyone has any ideas or had this problem and had this resolved, and also how they resolved it.

Hi Guys, if you tried all sort of troubleshooting to get your iphone back to charging again, you may want to visit my blog because I got some thing that might work for you. It worked for me. I got my 3Gs charging again. Some Tips that might help you.

http://thegizmoexpress.blogspot.com/2012/08/fix-iphone-3gs-charging-is-not.html
 

x-lil-sami-x

macrumors newbie
Sep 10, 2012
1
0
1. Turn on airplane mode
2. Turn phone off
3. Plug phone in pc/mac
4. Turn phone back on
5. Turn airplane off

should work from there!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.