Charging problem after disassembly

Discussion in 'iPhone Tips, Help and Troubleshooting' started by brobee, Jan 31, 2011.

  1. brobee, Jan 31, 2011
    Last edited: Jan 31, 2011

    brobee macrumors newbie

    Joined:
    Jan 31, 2011
    #1
    Hello

    I have just taken my 14 month iPhone 3GS apart to clean some dust out from under the screen that has been driving me crazy. Everything seemed fine afterward, all of the buttons worked, and the touch screen was responsive. Stupidly, I let the battery drain, and it shut itself off. Or I'm assuming that's what happened. It was at around 8% I think, the last time I looked at it before the apple logo popped up. But I had MyWi running, and the battery was draining fast. So I plugged it in, and after a while I noticed it was still off, so I pressed the power button, and the screen lit up white. I held down the home and power buttons until it restarted itself, and the apple logo appeared, only to turn back off after about 20 seconds. I've tried holding down the home and power buttons to reset it a bunch of times, and also just the power button, but it still turns back off after a few seconds. When I unplug it, and replug it, the apple logo pops up, and then disappears again. At one point, I got the dead battery screen, although I don't remember what I pressed to get that to come up. I've taken out the sim card, and tried different usb cords, and plugging it into both the laptop and wall.

    Does anyone have any ideas on what the problem is? I'm very worried. :\ Thanks for reading.

    Small update: I was able to put the phone into recovery mode, and it was recognized by iTunes as being an iPhone in recovery mode. Should I try restoring? I would rather not, as I've been hanging around on 3.1.3 for a while, and I don't want to lose my jailbreak by upgrading to 4.2. I also haven't synced it in a couple months.
     
  2. Amylittlehands macrumors newbie

    Joined:
    Feb 4, 2011
    #2
    My iPhone 3G is doing that, did your phone only show the Apple logo when it was plugged into the wall charger? I can't even get it into recovery mode or DFU mode, as soon as I take it off the wall charger it dies instantly.

    So annoying ><
     

Share This Page