Check Fusion drive?

Discussion in 'iMac' started by dokindo, Aug 18, 2016.

  1. dokindo, Aug 18, 2016
    Last edited: Aug 18, 2016

    dokindo macrumors regular

    Joined:
    Feb 4, 2009
    #1
    My 3TB HDD failed in my late 2014 iMac. It was a Fusion drive with a 128GB SSD.

    Apple replaced the HDD and I restored from a TM backup.

    Everything is running slower than I remember, which could just be spotlight re-indexing, or could it be Fusion drive is not working/seutp correct?

    Is there any way to check?

    Here is the output from diskutil list


    /dev/disk0 (internal, physical):
    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme *121.3 GB disk0
    1: EFI EFI 209.7 MB disk0s1
    2: Apple_CoreStorage Macintosh HD 121.0 GB disk0s2
    3: Apple_Boot Boot OS X 134.2 MB disk0s3

    /dev/disk1 (internal, physical):
    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme *3.0 TB disk1
    1: EFI EFI 209.7 MB disk1s1
    2: Apple_HFS Macintosh HD 3.0 TB disk1s2
    3: Apple_Boot Recovery HD 650.0 MB disk1s3


    And the output from diskutil cs list

    CoreStorage logical volume groups (1 found)
    +-- Logical Volume Group A7283685-80E4-40C2-950D-53CA2134834E
    =========================================================
    Name: Macintosh HD
    Status: Offline
    Size: 120988852224 B (121.0 GB)
    Free Space: -none-
    |
    +-< Physical Volume BEBA6AE4-1DD8-4E16-94C8-71FBFBFFFF4E
    | ----------------------------------------------------
    | Index: 0
    | Disk: disk0s2
    | Status: Checking
    | Size: 120988852224 B (121.0 GB)
    |
    +-< Physical Volume 302EAEE2-9B3F-4C99-A146-8803A5B64816
    | ----------------------------------------------------
    | (No properties)
    |
    +-< Physical Volume 1563B51F-E6D7-4009-BB84-375F3BAE0C44
    ----------------------------------------------------
    (No properties)
     

    Attached Files:

  2. IngerMan macrumors 6502a

    IngerMan

    Joined:
    Feb 21, 2011
    Location:
    Michigan
    #2
    It does not look right, Someone with more experience will chime in I hope. First off my Disk 0 is the spinner and Disk 1 is the 128GB SDD, not sure if that makes a difference. But your CS list acts like it is not fused and your SSD is completely full, that should never be the case.

    See my CS list below.

    Screen Shot 2016-08-19 at 8.14.55 AM.png
     
  3. dokindo thread starter macrumors regular

    Joined:
    Feb 4, 2009
    #3
    Thanks - I see your CS list showing 2 physical volumes which make up the LVG, which totals 2.1TB.

    Any suggestions on how to fix this, either myself or with Apple?
     
  4. IngerMan macrumors 6502a

    IngerMan

    Joined:
    Feb 21, 2011
    Location:
    Michigan
    #4
    This is a PM from Mike Flynn to me who helped me in this situation, I split up my fusion drive then I wanted it back, which I did via the instructions from the web link. Print out the instructions via the links.

    I created the Fusion drives via these commands:
    diskutil coreStorage create lvg-1 /dev/disk1 /dev/disk2
    diskutil coreStorage createVolume lvg-1 jhfs+ "Macintosh HD" 100%

    I then rebooted and reinstalled OS X.

    Use this link to see why I ran what I ran
    http://www.macworld.com/article/2014011/storage-drives/how-to-make-your-own-fusion-drive.html

    Conversely here's the link to split up the fusion drive.:
    http://www.macworld.com/article/2015664/storage-flash/how-to-split-up-a-fusion-drive.html
    --- Post Merged, Aug 19, 2016 ---

    The 2 physical volumes is my external time machine which but your HDD does not e
    My 2 volume groups is 1 Fusion Drive and 2 external time machine.
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    Yeah... you don't have Fusion setup there.

    Follow my instructions in post #5 of this thread to get the Fusion back, then you can restore.

    If that won't work (newer versions of Disk Util won't work like in post #5), follow my steps in post #11 of that same thread.

    Note you are fusing disk0 and disk1 like in my instructions, not 1+2 like Ingerman mentioned. I'm guessing he has more disks installed than you, and hence the difference.
     
  6. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #6
    I recently had issues with my Fusion drive that could only be qualified to becoming corrupted. I was at a point trying to install windows via bootcamp and that failed and rebooting showed me multiple Macintosh HD menu items.
    Additionally, the bootcamp partition was not showing up in OS X (not that I did anything as it failed on booting into it).
    Using diskutil, I saw the partition but bootcamp assistant nor Disk Utility found it.

    I couldn't even remove it by way of Diskutil cs delete. I had to use gpt to manually fix things.

    I'm all set now, but with the issues above, I wonder if something similar occurred to the OP
     
  7. dokindo thread starter macrumors regular

    Joined:
    Feb 4, 2009
    #7
    Thanks everyone for your quick and helpful replies, which confirmed that Apple did not fuse the drives after replacing the HDD.

    I contacted Apple support and they basically walked me through the same steps as Weaselboy's link to post 11 above.

    I then reinstalled OS X (which was Yosemite), then upgraded to El Capitan, and now am restoring from TM again. The first restore of 1.3TB took 12 hours, this one is estimating 7, so maybe the SSD is helping already...

    Thanks again!
     

Share This Page