Chirping sound from speakers?

Discussion in 'iMac' started by SMacDuff, Sep 30, 2011.

  1. SMacDuff macrumors 6502

    SMacDuff

    Joined:
    Oct 21, 2006
    Location:
    Stockholm, Sweden
    #1
    Normally I'm pretty good at accessing problems and fixing them without resorting to help from others but this one has me stumped. I bought a 27" iMac this past summer and have a pair of Harmon-Kardon Soundstick IIIs hooked up to an Airport Express so I can use Airplay to stream music to the speakers from the iMac as well as from my iPad and iPhone. Now, everything was working great until the past couple of weeks when, while playing certain mp3s, I can hear a loud chirping sound occasionally going with the beat (no birds stuck in my iMac :p). It doesn't happen with all mp3s, just certain ones. There are no Apple Stores here in Sweden and the closest Apple Authorized Repair Center is a good 75 minutes away by subway as well as by foot. I really don't want to lug this puppy all the way there.

    My guess would be mp3 file corruption normally but deleting the file and redownloading it from iTunes doesn't fix the problem and neither does ripping a new copy from a cd. I'm stumped! :confused:
     
  2. CubeHacker macrumors 65816

    CubeHacker

    Joined:
    Apr 22, 2003
    #2
    Very odd problem. Could you check to see if the problem also occurs on the iTunes 30 second preview? If it does, then give us a link to the song so we can check out if it happens to us too.
     
  3. NikFinn macrumors 6502a

    NikFinn

    Joined:
    Jun 22, 2009
    Location:
    MA
    #3
    Did you buy these mp3s through iTunes? I think I may be having the same problem, and didn't buy them. If there's enough interest/helpfulness I can upload a video with sound.
    Edit- Forgot to add, seems to only happen with external speakers (bose companion 2s in my case).
     
  4. SMacDuff thread starter macrumors 6502

    SMacDuff

    Joined:
    Oct 21, 2006
    Location:
    Stockholm, Sweden
    #4
    Sorry for taking so long to get back about this. In my case, it seems to be both iTunes and non iTunes songs. I'm still thinking that, somehow, those songs were corrupted in some way and will need to be replaced. However, even a fresh download of the song results in the same chirping sound. These are songs that played, and STILL play, perfectly on my iPhone. It does not happen during the preview.
     
  5. NikFinn macrumors 6502a

    NikFinn

    Joined:
    Jun 22, 2009
    Location:
    MA
    #5
    Me too. Do you happen to be running a beta version of iTunes?
     
  6. rahrah215 macrumors newbie

    Joined:
    Oct 10, 2011
    #6

    Are you using one of the beta versions of iTunes? I am using beta 7 or 8 and have the same issue. Like you, if I take the same audio file and play it using another application (i.e. VLC, Preview) I no longer hear the chirping / distortion noise. Some songs play fine and some songs play like crap. Very annoying none the less.

    I am hoping with Wednesdays release they will have this issue sorted out with iTunes.
     

Share This Page