chmod 744 /usr/bin

Discussion in 'Mac Basics and Help' started by irispiris, May 27, 2011.

  1. irispiris macrumors newbie

    Joined:
    May 27, 2011
    #1
    Hello.

    I was upgrading Ruby when I got message about it didn't have permission to usr/bin folder so I ran sudo chmod 744 (intended to run chmod 775). Thereafter I could not change the permission to /bin/ anymore, with nor without sudo (permission denied)

    Now basically nothing works on my mac.
    In a terminal I get ,,command not found" on every request, like ,,vi" ,,ruby" ,,env", "sudo" and whatever command that used to work. Furthermore the applications on my mac don't work anymore.
    Now the status on the /usr/bin folder is:
    drwxrwxr-- 1092 root wheel 37128 5 maí 09:46 bin
    (an old date, now is 27.may 2011)

    Are my problems due to the permission on the folder /usr/bin?
    What else could cause this?

    I also want to mention that the path includes /usr/bin, usr/local/bin, bins etc etc and looks normal.

    All the best.
    Íris
     
  2. Tumbleweed666 macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #2
    have you tried "Repair Permissions" via Disk Utility ?
     
  3. irispiris thread starter macrumors newbie

    Joined:
    May 27, 2011
    #3
    Thanks

    Thank you so much, it worked. YAY!
    Best regards
    Íris
     

Share This Page