Choppy 1080p video on my MBP

Discussion in 'MacBook Pro' started by Skika, Jan 25, 2010.

  1. Skika macrumors 68030

    Joined:
    Mar 11, 2009
    #1
    I have a MBP 15 with the 9600 gt and an Intel ssd x-25.
    Why do i experience choppy 1080p material (files that are over 8 gb)??.
     
  2. UbuntuFu macrumors regular

    Joined:
    Aug 16, 2007
  3. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #3
    Which codec do those 1080p videos use?

    Have you taken a look at Activity Monitor?

    I have the same problem on my 20" iMac, but I think the choppiness is due to the 1920 x 1080 being bigger than 1680 x 1050 or 1440 x 900 in your case.
     
  4. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #4
    Definitely need to know what codec/bitrate/playback program you're using.
     
  5. Skika thread starter macrumors 68030

    Joined:
    Mar 11, 2009
    #5
    Ive played two movies and they were both mkv. files.

    I have tried Plex and it is better! But does it support srt. subtitles? It didn't load them when i played the movie(i got the movie file and the subtitle file named the same)

    Why cant quicktime play this without a problem:(

    Oh, i forgot to mention i am not watching it on the mbp screen but via mini display port to a full hd TV.
     
  6. mrskitch macrumors newbie

    Joined:
    Dec 7, 2009
    #6
    VLC is tricky with MKV files. You have set a Loop off in some advanced setting inside VLC and that'll most likely fix the problem.

    I'll have to look at my settings at home and let you know. Its a pretty easy fix
     
  7. UbuntuFu macrumors regular

    Joined:
    Aug 16, 2007
    #7
    In Plex, I think you will have to check Automatically load subtitles and if it is named the same in the same folder it should do it. You can also manually load the subtitle file, while playing the mkv, press 'M' and load it from there.
     
  8. mrskitch macrumors newbie

    Joined:
    Dec 7, 2009
    #8
  9. Skika thread starter macrumors 68030

    Joined:
    Mar 11, 2009
    #9
    Yey

    i have changed the "output module" settings in vlc from "default" to "opengl video output"

    It now works smoothly!

    Tnx for all the help! :apple:
     
  10. Cave Man macrumors 604

    Cave Man

    #10
    Because Quicktime pretty much sucks.
     

Share This Page