Choppy video on new Macbook Pro 2.8Ghz

Discussion in 'MacBook Pro' started by MSUDVM, Nov 9, 2008.

  1. MSUDVM macrumors newbie

    Joined:
    Oct 20, 2007
    #1
    I upgraded my previous MBP to the new MBP. My specs are 2.8GHZ, 4GB RAM, and 300GB hard drive. The problem I am having is the display is beautiful with no issues except when I am on websites that display video such as webcams. The video is choppy and pixelated where it was not on my old MBD (spring 08 edition with 2.6Ghz, 4MB RAM, 300GB hard drive).

    Is there a setting I need to adjust or possibly a problem with my video card? The problem only exists with live video such as webcams. Thanks.

    Dan
     
  2. MBPDiva macrumors regular

    Joined:
    Nov 1, 2008
    Location:
    on Orion's Belt
    #2
    Sounds like you need to update your video drivers for your card.
     
  3. kolax macrumors G3

    kolax

    Joined:
    Mar 20, 2007
    #3
    Is this just website related? Try using Firefox and see if the problem persists. I recall a while ago people reporting similar problems to you.

    You are a Mac newbie I take it.
     
  4. MBPDiva macrumors regular

    Joined:
    Nov 1, 2008
    Location:
    on Orion's Belt
    #4
    Yes, why? :)
     
  5. kolax macrumors G3

    kolax

    Joined:
    Mar 20, 2007
    #5
    You can't "update" your graphics drivers on a Mac like you can on Windows. Apple will release a software update with new drivers.
     
  6. MBPDiva macrumors regular

    Joined:
    Nov 1, 2008
    Location:
    on Orion's Belt
    #6
    Okay, thanks. :eek:
     
  7. virtuatony macrumors regular

    Joined:
    Mar 9, 2008
    Location:
    Canada
    #7
    Is it like that with both graphic cards? In high performance and better battery life graphics modes?
     
  8. MSUDVM thread starter macrumors newbie

    Joined:
    Oct 20, 2007
    #8
    Sorry to be dumb, but how do I check the different modes? I only have the problem with live video web cam and it is the same on Firefox or Safari.
     
  9. Firefly2002 macrumors 65816

    Joined:
    Jan 9, 2008
    #9
    I think the real question here is why on earth you bothered to get a new MBP that's not any faster than your old one?
     
  10. MSUDVM thread starter macrumors newbie

    Joined:
    Oct 20, 2007
    #10
    Please stick to my original request for advice!
     
  11. DaveOZ macrumors regular

    Joined:
    May 13, 2008
    #11
    Go to System Preferences > Energy Saver and select Graphics : Higher Performance.

    See if that helps.
     
  12. DaveOZ macrumors regular

    Joined:
    May 13, 2008
    #12
    FWIW I have found the performance of the 9400M processor (the "slower" one) to be next to useless when driving my ACD external monitor. Even launching Dashboard is slow. When I turned on the 9600 it is much faster. I just leave it on now as battery life is not an issue to me.
     
  13. dr. shdw macrumors 6502a

    Joined:
    Aug 27, 2008
    #13
    Unibody?
     

Share This Page