choppy video playback 2015 macbook pro 13"

Discussion in 'MacBook' started by brfitzp, Aug 3, 2015.

  1. brfitzp macrumors newbie

    Joined:
    Dec 12, 2014
    #1
    So this is my first mac computer, its a 2015 rMBP, 13"

    8GB ram
    2.7ghz core i5 cpu

    When i try and play any video on youtube that is greater than 1080p i experience choppy video performance, 4k is unwatchable, and 1440p is hardly watchable either.

    Ive tried a bunch of youtube videos to see the picture quality and i've tried in both chrome and safari. Does everyone have this experience? Is there a fix for this?

    Here is an example of a video that plays poorly in 4k or 1440p for me:

     
  2. cbautis2 macrumors 6502a

    Joined:
    Aug 17, 2013
    #2
    You might want to get an exchange since mine works flawlessly on my i5 2011 MBA with ZERO dropped frames rendering at 4K but outputting to its 1440x900 resolution.

    Screenshot.png

    Maybe it's just your internet or YouTube server is throttling in your location since a meager 2011 MBA can play this without breaking a sweat.
     
  3. tbirdparis macrumors 6502

    Joined:
    May 30, 2015
    #3
    Not sure what might be going wrong at your end... I just tried the linked video here (switched it to 4K in the youtube settings) and it played perfectly on my 1.3 rMB, just as long as I paused it to buffer for long enough because my internet is currently not very fast here. Maybe that's your problem? If your internet download speed or your wifi router is too slow to get the data in time, then that would explain the problem because I don't see why are MacBook Pro with those specs shouldn't be able to play this.
     
  4. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #4
    Even my lowly 2008 MacBook plays the video without stuttering.
     
  5. cbautis2 macrumors 6502a

    Joined:
    Aug 17, 2013
    #5
    Core 2 Duos can play 4K without stuttering so it's definitely your internet connection.
     
  6. brfitzp thread starter macrumors newbie

    Joined:
    Dec 12, 2014
    #6
    My internet connection is 75 megabit, that should easily be sufficient for that video. It shows that the video has buffered far ahead of my location in the video.

    I did a PRAM reset and upgraded to 10.10.4 and it seems to play fine now.

    Also, i realized that i posted in the wrong forum but everyones replies here show that much older cpus and much slower ones can push those videos along with out a problem. So something is odd here.
     

Share This Page