Chrome browser problems?

Discussion in 'Mac Apps and Mac App Store' started by rgr555, Oct 9, 2013.

  1. rgr555 macrumors 6502

    Mar 8, 2012
    What's wrong with Chrome browser for OSX? I'm using MBPr with latest OSX.

    -Youtube videos stop half way
    -Sound doesn't work sometimes until reboot

    Safari works fine all the time. But I prefer to use Chrome. Are there any fixes?
  2. rabidz7 macrumors 65816


    Jun 24, 2012
  3. rgr555 thread starter macrumors 6502

    Mar 8, 2012
    Just did. Didn't change anything.

    This is frustrating, any other clues? Flash is updated.
  4. CoMoMacUser macrumors 6502a

    Jun 28, 2012
    YouTube works fine for me, but about two months ago, it started hanging when loading pages. Sometimes I have to Force Quit it. This problem occurs on both my 2012 MBA (Mountain Lion) and 2008 iMac (Snow Leopard).

    Until Google pushes a stable update, I've gone back to Safari as my main browser.
  5. ObiJuan2080 macrumors newbie

    Aug 2, 2012
    New York City
    Trying Emptying the Cache (Settings>Privacy>Clear Cache). Let me know if it works.
  6. rgr555 thread starter macrumors 6502

    Mar 8, 2012
    Tried a long time ago. That doesn't work unfortunately..
  7. LPZ macrumors 65816

    Jul 11, 2006
    Maybe try completely uninstalling Chrome and then reinstalling. Quit Chrome. Then trash Chrome-related preference and support files. Get rid of in ~/Library/Preferences. Get rid of the Chrome folder in ~/Application Support/Google. Get rid of any Chrome extensions.

    Then trash the Chrome application, empty the trash and reinstall. And hope.
  8. rgr555 thread starter macrumors 6502

    Mar 8, 2012
    I just deleted all plug in extensions except Adblock and Adblock Plus and so far so good.
  9. rillrill macrumors 6502a


    Jul 27, 2011
    New York
    i still have the problem with my display turning off while using chrome on a macbook air. i would have to restart the machine to get my screen back. reports said it was chrome's fault, but i didn't believe them because it seemed too weird for a browser to have a bug like that. finally i got sick of it and deleted chrome. no more blackouts so far.

    anyone know the solution? it's not reinstall chrome fyi.
  10. rgr555 thread starter macrumors 6502

    Mar 8, 2012
    I've had that happen to me before too. No clue if Chrome is even responsible. Doesn't happen often though

Share This Page