Chrome Multitouch "Back/Forward"

Discussion in 'Mac OS X Lion (10.7)' started by vomer, Jul 4, 2011.

  1. vomer macrumors member

    Joined:
    Sep 13, 2007
    #1
    Hi Guys,

    Ever since I switched to lion I have been missing going back or forward in Chrome using multitouch gestures.

    I found the same with Finder...cannot go 1 dir up using gestures

    Anyone found a fix for this?

    Edit:

    Found fix :

    Go to Trackpad in System Preferences, More Gestures tab, and change "Swipe Between Pages" to "Swipe with Two or Three fingers". This will also allow you to swipe back/forward in Firefox, the Finder, iPhoto and other apps again with a three finger swipe.
     
  2. aleD macrumors newbie

    Joined:
    Jan 6, 2010
    #2
    chrome multi touch crashes

    Chrome seems to crash when I try to use the three fingers sweep.
    In Safari it works fine
     
  3. hyperpiper45 macrumors regular

    Joined:
    Dec 11, 2007
    Location:
    Calgary, Canada
    #3
    do you have multi clutch installed? this made chrome crash for me until i removed it.
     
  4. ryanbridgwood macrumors member

    Joined:
    Nov 23, 2009
    #4
    Brilliant, thanks, was wondering how to do this in Chrome.
     
  5. aleD macrumors newbie

    Joined:
    Jan 6, 2010
    #5
    removed and restarted but still crashing when doing three fingers swipe...
     
  6. ghsNick macrumors 68020

    ghsNick

    Joined:
    May 25, 2010
    #6
    Check this out if you want to use natural but it's not working in Chrome.
    I think Chrome is going to fix it...because this solution works the best (for me) in Safari.
     
  7. ahdickter macrumors 6502

    Joined:
    Jun 12, 2011
    Location:
    Pittsburgh, Pennsylvania
    #7
    The program hasn't been updated yet with the new gestures
     
  8. aresinferno macrumors regular

    Joined:
    Oct 13, 2008
    #8
    I too am getting crashes when trying to use three-finger gestures. I have fiddled with the trackpad settings and can't stop it from crashing. The best I could do is to use BetterTouchTool in agressive mode. The crashes still happen but not all the time.
     
  9. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #9
    A couple of other Chrome anomalies that I have noticed. In full screen mode you can't use the Escape key to exit. Also the scroll bars stay on/visible even when I have then set to only display when scolling.
     
  10. Elven macrumors 6502a

    Elven

    Joined:
    May 13, 2008
    Location:
    UK
    #10
    Using Chrome here and no problems with the three finger swipe on Lion :confused:
     
  11. aresinferno macrumors regular

    Joined:
    Oct 13, 2008
    #11
    Are you using the stable release of chrome? Or perhaps beta? I remember seeing a permanent scrollbar in one of those. The dev and canary releases have the standard lion scrollbar like other applications. The fullscreen button on the top right has been removed in these newer releases as in the older ones it did not implement the standard Lion way of dealing with fullscreen. Instead the button simply did what View -> Enter Full Screen would do. It will be added again once they have added the proper functionality.
     
  12. hyperpiper45 macrumors regular

    Joined:
    Dec 11, 2007
    Location:
    Calgary, Canada
    #12
    Make sure you remove the original multiclutch input manager from /Library/InputManagers.
     
  13. aresinferno macrumors regular

    Joined:
    Oct 13, 2008
    #13
    You are one genius. That fixed everything. Ever since I removed MultiClutch, I felt that it was still doing something. Removing that fixed the crashes. I am so happy right now.
     
  14. aleD macrumors newbie

    Joined:
    Jan 6, 2010
    #14
    That solution finally worked for me as well. Thanks indeed!
     
  15. regnoc macrumors newbie

    Joined:
    Apr 23, 2009
    #15
    Attempted terminal

    defaults write com.google.Chrome AppleEnableSwipeNavigateWithScrolls -bool FALSE
     

Share This Page