Chrome oddly crashing without reason! D:

Discussion in 'Mac OS X Lion (10.7)' started by iParis, Mar 5, 2013.

  1. iParis macrumors 68040

    iParis

    Joined:
    Jul 29, 2008
    Location:
    New Mexico
    #1
    So for some reason chrome keeps crashing on me. Not the usual crash that will sometimes make sense due to doing a lot of things or an unresponsive webpage, but it happens out of nowhere. Often it's as soon as I open up chrome and type in the first letting of the page I want to visit and it instantly disappears. It will happen multiple times in a row, or sometimes work right away. Sometimes it even happens if I just open a new tab and begin to type my desired website. No slow down or anything, just instantly gone. What's even stranger is it doesn't give me a notification it's crashed, though I end up randomly getting the notification when browsing without issues. I have no idea how to fix this issue or what would cause it.

    Any suggestions? Thank you! ="^_^"=
     
  2. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #2
    1. Do you have the latest version, no, download newer version.

    2. Try deleting Chromes preference file in the Preferences Folder, I don't have chrome so I don't know the files name but should be similar to com.chrome.plist.
    You can actually find the name, if you right click on the Chrome App and show contents, go to the info.plist and it will tell you the Apps identifier string.
     
  3. iParis thread starter macrumors 68040

    iParis

    Joined:
    Jul 29, 2008
    Location:
    New Mexico
    #3
    Do I reinstall the file somehow afterward? Or is this setting file not necessary?
     
  4. justperry, Mar 5, 2013
    Last edited: Mar 5, 2013

    justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #4
    Late response, different timezone likely.

    I think I have to explain it a bit farther.

    You know all/most Applications have preferences, those preferences are saved in so called .plist files inside your Preferences Folder or if the Applications is system wide in the Main Preferences folder.
    These files do sometimes cause problems.

    So:

    /Users/****/Library/Preferences for your Preferences **** = Your User Name
    ?Library/Preferences for System wide Preferences.

    This file will reside in the first one, I am downloading Chrome now but it will take a time, I am over my internet Cap, 128 KB now.
    When I am done I wwill tell you exactly what to delete.

    In the mean time, if you read this before I come back you could try to login into a different user and see if the problem is there, if not then it's 100% to be sure to be in the Normal User account.

    If you don't have another User account make one in User and groups, logout and into the new User Account and see how chrome does there.

    Oh, and for your question, no, the file is automatically recreated, but you loose Chrome settings, you also have to quit and restart Chrome for this to work.

    Update: I installed Chrome, the file you are looking for is named : com.google.Chrome.plist
    Delete that file and see how it goes.


    I have a program which finds any file, after I launched Chrome I used this program and let it search for files created in the last minute, chrome created more than 500 files, WTF, not my kind of program, don't really like google if I am honest.
     

Share This Page