Chrome uses a lot of CPU with flash!

Discussion in 'Mac Apps and Mac App Store' started by kristoffer4, Apr 7, 2011.

  1. kristoffer4 macrumors 6502a


    Jan 17, 2006
    So I been using Chrome as my main browser for a while and all in all I like it.
    But when I view a flash video in Chrome the CPU usage can get as high as 100 pct! :eek:
    Watching the same video in Firefox uses half or less!
    This video gives me 100 pct. in Chrome.

    Could this have anything to do with the build in flash player in chrome? :(
  2. AlanFord macrumors regular

    Feb 26, 2011
    Hmm, tryed with firefox 4, and cpu is btw 8-13%.
  3. kristoffer4 thread starter macrumors 6502a


    Jan 17, 2006
    What machine are you on? I am on a old MB white but that still does not explain the huge difference I am seeing in CPU usage.
  4. AlanFord macrumors regular

    Feb 26, 2011
    Ok, so I did a little bit of testing.Here are the results:
    Chrome: 19-23%, and Safari 8-9%, (FF as mentioned above 8-13%).
    So, you can try with safari.Personally I recently switch from pc to mac so I am used to FF, but while browsing I can say that safari give's a pretty nice results and work.So why don't you try and see?
    Dunno if your mac is a problem, at least I think it shouldn't be.Like you sad, the difference is really huge.I am using a new 2011 mbp 2.0 i7.
  5. kristoffer4 thread starter macrumors 6502a


    Jan 17, 2006
    Well the thing is for everything else Chrome uses less CPU and I don't really like Safari. It just looks like there is a bug in Chrome.
  6. Icy1007 macrumors 65816


    Feb 26, 2011
    Cleveland, OH
    Flash on Chrome seems to use significantly more CPU than Flash with other browsers. I've tested it with Chrome on OS X and Windows 7. Just sitting at the MacRumors homepage will make Chrome use 15% of my CPU on both Win7 and OS X. If I switch over to Safari it goes down to 0.0%~0.1%.

    I'm typing this post in Chrome on OS X and Chrome is using over 50% (so half of one core). Shockwave Flash plug-in is using 18%, Chrome Renderer is using 14% and Chrome is using 15%. There is also a second Chrome Renderer using 4%.

    Until this is fixed, I'm just going to stick to Safari.
  7. Young Spade macrumors 68020

    Mar 31, 2011
    Tallahassee, Florida
    Interesting; yea right now I have 5 pages open and it's using less than 5%; of course, I'm using Canary but... I don't see how you guys have such high usage.

    But yea, I installed "Click to Flash"; I would recommend you guys check that out. I just have it enabled and disable it whenever I"m watching a movie.
  8. Splen macrumors newbie

    Aug 24, 2010
    I have been having this problem as well. I have just installed click to flash and it appears to have got the cpu usage down to around 25% (give or take), a definite improvement on the 100%+ that I was previously experiencing.
    So far I have only tried it out for about an hour of full screen flash movie watching on this site: but as I said, the problem seems to have gone! Thanks 'Young Spade' for the heads up :)
  9. fireshot91 macrumors 601


    Jul 31, 2008
    Northern VA
    I think it's a problem with Flash, not so much Chrome.

    Get rid of Flash, and we're okay :p
  10. r0k macrumors 68040


    Mar 3, 2008
    I install flashblock as my first add-on with Chrome. I can click to play flash or even enable flash for an entire site (like so I can listen to previews), but I'm not faced with hearing my Macbook's fans rev up to maximum every time I launch Chrome with a few dozen tabs open.

    I try to avoid Safari but sometimes it's necessary. I avoid Firefox altogether as it eats all my memory after a while.
  11. Young Spade macrumors 68020

    Mar 31, 2011
    Tallahassee, Florida
    NP: Read below quotes.

    Flash is terrible.

    ^This. When using it, all flash is disabled and, personally, I use "click to flash" to only watch what I want. This disables flash ads, flash content, flash video, everything. I also used it back when I had a Nexus 1 to keep bandwidth and cpu usage down as well.
  12. waterhead macrumors newbie

    Jan 15, 2011
    I also have this issue with both Chrome and Firefox. 2010 i7 mbp 6,1 using OSX 10.6.8 .

    Chrome uses about 70-80% cpu, along with a separate chrome flash plugin using a bunch as well.

    Firefox uses about 60-70% cpu with the firefox flash plugin using ~40%.

    Safari uses 3% with the safari flash plugin around 25%.

    The fan was going crazy until I switched to Safari. I prefer the other browsers but those numbers are crazy.
  13. JonasDK macrumors member

    Aug 18, 2011
    Before buying a Mac I also preferred both Firefox and Chrome over Safari. Now, with my iMac, I only use Safari. It just feels more integrated with the OS, which of course it is.
  14. iphonsteve4ajob macrumors regular

    Aug 6, 2011
    I'm also curious what machine you're on. Flash kicking CPU to 100% has been an on going issue on both PC's and Mac's for quite some time. My previous Dell PC couldn't get through a minute of Flash before hitting 100% and locking up the whole computer.

    Quite frankly I've never found a proper resolution to this issue. There are so many methods and reasons for Flash working for some computers, while others not. I gave up and bought myself a new MBA.

    Seems to constantly stay around 10% running Flash. Only Silverlight on Netflix kicks CPU up to 30-40%. Tested Flash on FF, Chrome, and Safari same results.

    So in the end my only solution (thankfully it worked) was to buy a new computer. :eek:
  15. naix macrumors member

    Dec 31, 2010
    hey chrome has a built in flash block. go to about:flags and choose "click to play" then go to preferences, under the hood, and content settings. Then scroll down to plugins and choose "click to play".

    This blocks all plugins though but you can click to play them.
  16. wngoju macrumors newbie

    Mar 9, 2010
    Try "Run PPAPI Flash in the renderer process"

    Older thread, but, fyi...

    Setting the flag "Run PPAPI Flash in the renderer process" to Enable seems to make Chrome/Flash use less cpu for me. (Beta version of Chrome)

    Flash is taking ~20% of cpu on a MBA 11-inch 1.6GHZ, Lion, with occasional up-spikes of a second or three.

    I typically run a bunch of stock charts open which use flash, and before enabling PPAPI flag, 'ol Flash could be observed to be taking 30-40% in past; sometimes more.

    I can actually get some work done now!

    Highly scientific report here...
  17. rcavallaro macrumors newbie

    Sep 7, 2012
    Fixed: Chrome and Flash video using 100% CPU

    Found the issue, it has to do with the standalone version of Flash and Chrome's integrated Flash conflicting with one another, trying to load both at the same time

    Do the following:

    -In Chrome address back type about:plugins (no space between colon and plugins)

    -This will bring up a list of plugins

    -Look for the Flash plugin and when you find it, it may say 2 or more files. For example mine said 3 as shown here: Flash (3 files) - Version: 11,4,402,265

    -Over to the far right is a DETAILS link. Click on it. This will bring up details for each file/version you have installed

    -Look at the ‘Location:’ of each version – some may be the integrated Chrome version (…Application Data\Google\Chrome etc) and the other is the standalone Adobe (formerly Macromedia) version which is in the …Windows\system32\Macromed\Flash etc directory.

    -You don't want the integrated Chrome version(s). Click on ‘Disable’ just under the Location(s) of the Chrome version to disable it (and it will become greyed out)

    -Ensure that the standalone Adobe version is still enabled – if it is disabled (greyed out) click the ‘Enable’ link just under its Location to enable it) then close the Plugins tab

    You're good to go. This should get rid of Flash constantly using 100% cpu for Flash videos
  18. soloer macrumors 6502a


    Sep 27, 2004
    Wow, nice 9-month thread bump!

    What's the reasoning behind disabling the integrated version of flash in chrome instead of disabling the standalone version of flash in chrome? If the issue has to do with a conflict between the two, wouldn't you want to disable the non-native version (for chrome)?
  19. blatopilot macrumors regular

    Sep 24, 2011
    You could just change the plugin setting to "click to play".

    I''m not currently using my Mac, so I'm going by memory, but:

    Click the wrench -> settings Under, "Content settings" you should see plugins. Select "Click to Play". Click to play means unless you click to activate, the plugin won't activate.

    So for a video you would click the container, otherwise it won't load there or anywhere... It's like flashblockers, but without an extension and better in my opinion.

Share This Page