CIFS not working?

Discussion in 'macOS Sierra (10.12)' started by yergnov, Aug 4, 2016.

  1. yergnov macrumors newbie

    Joined:
    Jan 11, 2011
    Location:
    MSP
    #1
    I am the only Mac user on in a PC environment on the condition that I provide all my own technical support. I am somewhat technical, but this eludes me...

    I am running the Sierra now V.3 beta update. On Yosemite, I was able to connect to our network by using a Go To Folder: cifs://folder_name path. Since the update, I am unable to connect. Does something need to change on the Mac or on the windows server to allow me to have access? I am afraid if I can't connect, I will be on the radar which I have worked hard to stay off of for many years.

    I have also tried smb:// but that does not work either. And that, is the extent to my MS networking understanding...

    Thanks in advance for your help.
     
  2. fischersd macrumors 601

    fischersd

    Joined:
    Oct 23, 2014
    Location:
    Kitchener, Ontario, Canada
    #2
    A little surprised that you upgraded your work PC (seemingly from Yosemite to Sierra beta 3?) Might have been good to upgrade to El Capitan first, as that code is going to be more similar to Sierra. Especially considering you're supporting yourself (beta's often aren't that stable).

    Any who - one thing you can try is to see if the problems aren't due to macOS having issues resolving your server names. Hopefully you wrote down all of the connections you made in the past. At a terminal prompt, try typing (without quotes) "host server_name" (where server_name is the name of the server you're connecting to). If you don't have your DNS setup properly, all of the paths you were trying to connect to won't resolve.

    Then try fixing your DNS entries on the Mac to be what they would have been on any other PC in the office. (these should normally be provided by your DHCP server - but maybe your Mac isn't receiving that information correctly - or maybe you configured your TCPIP to a static address, but didn't enter the DNS entries.

    If your DNS is working properly and you're still not able to connect to these shared resources, you could try hard coding them (but, when the IT guys change the IP addresses of the servers, your connections will stop working) - something you'd need to fix later.
    How that would work is, in finder you would click Go, Connect to Server, then enter SMB://10.0.0.4 (for example - insert the IP address of the server there (that's an IPv4 address....if your network is IPv6, it's considerably longer) :) You should be prompted for your username / password - if you save your password in your keychain you'll be fine until you hit the expiration timeout on the windows domain (many businesses are 90 days), then you'll need to go into passwords and change them.

    Let me know if that helps at all....cheers!
     
  3. yergnov thread starter macrumors newbie

    Joined:
    Jan 11, 2011
    Location:
    MSP
    #3
    --- Post Merged, Aug 4, 2016 ---
    Thanks fischersd. I was able to access via IP. I don't know why it won't resolve, but think I may have to double check the ip addresses of the DNS servers.

    I realized that I did go from El Capitan, but forgot the name (I should have gone by the OS X number).

    I understand the risks with the betas- I have had really no issues other than the networking. I did make a full backup and was prepared to go clean if necessary.

    Thanks for your help!
     
  4. donlab macrumors 6502

    donlab

    Joined:
    Jun 3, 2004
    Location:
    USA
    #4
    What version of CIFS is your Windows server providing for client access? What versions of CIFS is Sierra compatible with? These are some troubleshooting starting points.
     

Share This Page