Cinema Display Dead? Any one else with this problem?

Discussion in 'Mac Accessories' started by computerman-8, Nov 22, 2010.

  1. computerman-8 macrumors member

    Joined:
    Oct 11, 2007
    #1
    After 2 and a half years, my 23" Cinema Display just stopped working. All USB ports, firewire ports and the monitor itself. Now, I try to connect it to my MacBook Pro again and I notice the light on the screen goes on for 1 second and then shuts off. Still nothing displaying. I'm assuming its some hardware problem and that the display is giving up. I find it frustrating that paying around 1000$ for a screen like this just gives up in this short time.
    Is there any one else that this happened to?
    How much is a hardware repair on these screens?
    Do you think theres a way to make Apple give a discount on a new one or something?
     
  2. ShiftClick macrumors regular

    ShiftClick

    Joined:
    May 9, 2010
    Location:
    Los Angeles
    #2
    applecare?

    You mentioned in your post that it is only 2.5 years old. Wouldn't it still be covered by applecare?

    If you are not covered by applecare I would suggest your local authorized apple repair shop. Sounds like a power supply issue so hopefully it's not that expensive. Good Luck
     
  3. computerman-8 thread starter macrumors member

    Joined:
    Oct 11, 2007
    #3
    Unfortunately I didn't take applecare on it, I did some research and it seems like it's a 400$ repair.. ouch
     
  4. Eclipse278 macrumors regular

    Joined:
    Jan 21, 2007
    #4
    most cinema display issues are with the power supply, so hopefully you can get away with just a new one of those for like $80.
     
  5. bartsphoto macrumors member

    Joined:
    Nov 13, 2008
    #5
    I just had that happen

    I Just had that happen to me this week on my 2007 23'' display I Just see the flashing light going on for like 2/3 times and then it stops and it starts up again.
    I went to the apple store and it work for them they said they will give me a new power brick so they did I took it home and it still dont work.
    So i am taking it back for round 2 this time I took a video of it.
     

Share This Page