Cinema Display not working on boot

Discussion in 'Mac Accessories' started by Morgan Stack, Mar 25, 2014.

  1. Morgan Stack macrumors member

    Joined:
    Jul 24, 2011
    #1
    The monitor isn't working. A 24" Apple cinema display monitor. It's connected up to a Mac Pro processor at the back, and has been working without issue since 2009. Yesterday, I turned on the power and the computer began to boot up, except the monitor didn't light up as it usually does. It flickered bright white for half a second, and then the screen blackened again. No matter what I do, I get no response from the monitor after that. I've tried tweaking wires, removing devices, switching power sources, and always get the same response. This happened yesterday, and after maybe 20 tries, the monitor eventually stuck, and it worked correctly for the rest of the day. Today, the issue returned. Again, after maybe 20 attempts at turning off and on the computer, the screen stuck, and now it's working again, for the moment.

    I would suggest that there is something wrong with one of the wires, or the monitor, but I think it could be something else. A few months ago I purchased a HP keyboard to use in lieu of the many **** Apple ones that were causing much grief. The HP one works correctly and I've had no problems. Like the Apple keyboard, the HP one has a feature that when you press F14 and F15, they control the brightness meters of the monitor. F14 brings the brightness down, and F15 brings the brightness up. The other day, I used F14 to bring it down fully, and after a few levels, the screen flickered and then shut off completely. There was nothing to do except turn off the computer; when I turned it back on, it was back to normal. But since then I was cautious using the brightness feature. It happened again a second time as well. I'm wondering if this could have something to do with how the monitor is behaving now. Maybe the 'apple script' that allows the feature to work is tampering with the monitors ability to work when the computer boots, or something. I'm fairly confident that it is not a hard ware issue, and has something to do with the script that tells the monitor when to turn on, and adjust the brightness levels. But I don't know, maybe it is hard ware related.

    In any case, this is a problem. I don't dare turn off my computer lest it doesn't turn back on. I can't afford to purchase new cables on the off-chance the problem is hard ware related. If there any way to determine if the issue is something to do with the script that tells the computer how to behave when it initially boots? I'm not sure what the problem is here, but I know it will persist unless I do something about it. Apologies for the long wall of text.

    [​IMG]
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    You are a bit all over the lot here. It is not if you are a more concerned about problems with you Apple Cinema Display or if you want to take the opportunity to praise HP.

    My own experience with Apple Cinema Display flat panel monitors has been excellent. The ACD that I using to write this response is 10 years old. The ACD attached to my Power Mac G5 at work is 9 years old. Neither monitor has given me a microsecond of trouble.

    That said, your computer is 5 years old. Some things may need to be replaced. I seem to recall a graphics card going bad several years ago. Your PRAM battery is probably hanging by a thread. I would trot the computer to the nearest shop that has a Mac technician. Pay someone who knows what he is doing to diagnose your problem and fix it.
     
  3. Morgan Stack thread starter macrumors member

    Joined:
    Jul 24, 2011
    #3
    rEFIt

    There's always a bastarding problem just waiting around the corner with computers. They seem to be getting more serious.

    Just last month, I suffered a very serious problem with a small piece of software called rEFIt that refused to let me boot into any of the three OS's that I had installed. The software is supposed to make dual-booting easier, but the previous stable release ended at OS X 10.2, and I therefore took a risk using it. It was always a bit screwy, and one day it stopped working altogether, effectively locking me out of my computer.

    If only I was able to log in one more time to remove the tiny 6.5MB file, then everything would be OK, but that would first require getting past the problem of rEFIt. There seemed to be no way around the problem, short of formatting the hard drive. I tried everything I could think of, even using a test CD of a Linux distribution that would allow me at least to get into the system so I might be able to remove the software from that side, but no luck. To think that the operating systems, the applications on them, the files, the preference files, all of which have great importance, were so close, and yet so far. That they would unfortunately have to be formatted because of a tiny piece of software..

    In the end, I found that I hadn't thrown out the original boot CD of Snow Leopard, that has a feature of de-fragmenting the drive, or something, that allowed me safe access into the drive again. It worked, and I immediately removed rEFIt. It was a genuine scare for a while. I was certain everything was lost because of one slip up. The moral is to be careful with software that has exclusive access to the basic functions of your computer. If they get buggy, then you're left in a bad place.
     

Share This Page