Resolved Cinema/Studio Display - Blinking Power Light, One Solution

Discussion in 'PowerPC Macs' started by eyoungren, May 19, 2015.

  1. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #1
    So, I came home tonight to find that the 20" Cinema Display for my QS is dim and the power light is flashing slowly.

    Restarted the Mac. No fix. Had to go out and decided to look it up a little later.

    I'm thinking backlight and while that could be an issue it wasn't in this case. I ran across a very simple solution from the Apple discussion forums in 2008.

    With only the money I'd use to buy a new backlight at stake I did the following.

    1. Shut down the Mac.
    2. Disconnect the ADC cable from the converter box (or video card if you directly connect).
    3. Reconnect the ADC cable.
    4. Restart the Mac.

    As the user who posted this advertised, it solved my problem.

    Putting this out there in case anyone on Google needs it or anyone here.
     
  2. A.Goldberg macrumors 68000

    A.Goldberg

    Joined:
    Jan 31, 2015
    Location:
    Boston
    #2
    Thanks for the info. That's an odd issue, but I think I remember reading the ADC to DVI converter boxes being occasionally flakey long ago. Glad to see you've resolved the issue (without replacing the backlight).
     
  3. eyoungren thread starter macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #3
    Updating this as it's an issue I've had for a while.

    I did not comment about a later discovery and that is simply that if I wait for a while for the display to heat up I can unplug the ADC cable from the converter box, plug it back in and that somehow kicks the lower backlight back on. That of course, stops the display light from blinking. And I once again have full brightness.

    Once I discovered this, it became a routine habit whenever the blinking light happened. With my G5 replacing my G4 I did not expect it to go away and after a week or so of use I was right. But it's such a thing now that while still bothersome, I just roll with it.

    But today I noticed something else. I usually leave my browser running all the time and the Mac just shuts the screens off. When I do that I usually just leave the browser on Google, which is my homepage. For me that's a dark page because I have the Stylish addon running.

    It occured to me to try something. The next time I left the Mac running I left it on MacRumors, specifically because MR has a lot of WHITE. Upon returning to the Mac a few hours later I had no blinking light and the display worked normally.

    I tried this twice and both times no issues. The last two times before this I had issues and that was when the Mac was left on a dark web page.

    This is entirely unscientific. But I will continue now to leave the browser on a white web page and see what happens when I return.
     

Share This Page