Circus Ponies Notebook: read only when moved to new computer

Discussion in 'Mac Apps and Mac App Store' started by frowzy, May 21, 2017.

  1. frowzy macrumors newbie

    Joined:
    May 21, 2017
    #1
    I just got a new MacBook Pro with Sierra (10.12.4). I transferred my Circus Ponies Notebooks (CPN) to the computer and the app is working in that I can open them and read them. But when I try to save, it says it can't. Read only. For one notebook only, it asked if I wanted to open it as read only or to make changes. I clicked "make changes" and now that one single notebook works. I have not been able to get that option to appear for any other notebook. I have also tried clicking "get info" and changing the permissions to "Read write" but even that has not worked.

    Other users have said CPN works on Sierra, so I know it's possible.

    Does anyone have suggestions?
     
  2. casperes1996 macrumors 65816

    casperes1996

    Joined:
    Jan 26, 2014
    Location:
    Horsens, Denmark
    #2

    In the Terminal, try using sudo chmod 644 [PATH TO FILE]

    This will ask you for your password, and then give you read+write access, and all other users read only access. If you want to disable all access for other users, simply use 0 instead of 4.
     

Share This Page