Cisco AnyConnect no longer works under 10.9

Discussion in 'OS X Mavericks (10.9)' started by acrafton, Oct 25, 2013.

  1. acrafton macrumors 6502

    Joined:
    Jan 18, 2006
    #1
    So. . updated to 10.9 and all of a sudden Cisco AnyConnect no longer works which means I can't get to my work intranet. I updated to the latest version that is supposed to work but I can't get a connection to start. It tries and then comes back with this msg:

    "The VPN client driver encountered an error. Please restart your computer or device, then try again."

    Restarting, re-installing, etc doesn't work. The message log for AnyConnect has these msgs:
    Oct 25, 2013, 4:11:56 PM] Establishing VPN session...
    [Oct 25, 2013, 4:11:56 PM] Establishing VPN - Initiating connection...
    [Oct 25, 2013, 4:11:57 PM] Establishing VPN - Examining system...
    [Oct 25, 2013, 4:11:57 PM] Establishing VPN - Activating VPN adapter...
    [Oct 25, 2013, 4:11:57 PM] Disconnect in progress, please wait...

    So it looks like it tries to activate the VPN adapter (I don't know what that is) and then dies.

    I do know that most everyone at work has it working fine under 10.9 and the latest AnyConnect so it must be something with my computer, I just can't figure out what it is.
     
  2. grille macrumors newbie

    Joined:
    Nov 12, 2012
    #2
    Hi, I don't know the us translation in mac, so I add a picture of the internet.

    1. try)
    On one MB i get lucky by repairing rights in HDDmanager.
    http://www.macwelt.de/images/19/1/0/4/4/2/3/5/012394874bd85e9d.jpeg

    2. try)
    And on my second MB i had to reinstall AnyConnect, but i think it was the missing JRE which needed to be installed before AnyConnect.

    But remove anyConnect and rename /opt/cisco in terminal as root.



    Hope one of these helps ... let me know


     
  3. metier macrumors member

    Joined:
    Feb 20, 2012
    Location:
    Texas
    #3
    Sorry not much help but, I have no problems on 3 mac's that I have upgraded, a MBPr, air and Mac Mini. I'm running version 3.1.04066 on all 3. I've connected through anyconnect both wired and wirelessly.
     
  4. DiscardedPacket macrumors member

    Joined:
    Mar 8, 2013
    #4
    Working fine for me on 10.9 with the same version as you....

    Do you use the built in OSX VPN client as well? I have noticed running both at the same time can cause issues with AnyConnect client, which then requires a reboot.

    I would try uninstalling and attempting to remove all components of the AnyConnect client, then reinstalling. If this fails, then a maybe a clean re-install of Mavericks may be your only option?
     
  5. TookiTheGreat macrumors newbie

    Joined:
    Oct 25, 2013
    #5
    Cisco Anyconnect stopped working for me too

    I have upgraded my MacBook Pro Retina to Mavericks and AnyConnect stopped working straight away with the "The VPN client driver encountered an error. Please restart your computer or device, then try again." message. I have tried the repairs in the posts above, to no avail. Could it be a problem with the Jave runtime? If so, how to fix that?
     
  6. dmkahn macrumors newbie

    Joined:
    Aug 1, 2011
    #6
  7. TookiTheGreat macrumors newbie

    Joined:
    Oct 25, 2013
    #7
    Mavericks Cisco Anyconnect Problem

    The bug reported is about intermittent dropouts. The bug I experience prohibits any connections at all. The connection fails as soon as the VPN adapter is activated. Does anyone else have this problem?
     
  8. chazer1 macrumors newbie

    Joined:
    Oct 27, 2013
    #8
    Cisco AnyConnect OS x Mavericks connection problem

    Having exactly the same problem on both my iMac and my macbook pro.
    Using Cisco AnyConnect Secure Mobility v3.1.01065 and connection fails every time.

    I get the following message:
    "The VPN client was unable to successfully verify the IP forwarding table modifications. A VPN connection will not be established."
    followed by:
    "AnyConnect was not able to establish a connection to the specified secure gateway. Please try connecting again."

    Any Ideas?


    -Chaz
     
  9. acrafton thread starter macrumors 6502

    Joined:
    Jan 18, 2006
    #9
    Update. ..

    Could not get it to work. I did get disk errors while running disk utility that said to boot in restore mode and fix. When I did that it detected no errors. I eventually just did a clean install and it worked.

    There are a few folks out there seeing the same problem but it seems to be a very small number of users.

    Thanks for the help.
     
  10. TookiTheGreat macrumors newbie

    Joined:
    Oct 25, 2013
    #10
    Mavericks Cisco Anyconnect Problem

    @Chazer1: Mmmm. Maybe there is a problem with the Firewall? I have tried turning Apple's firewall on and off, but it didn't seem to make a difference. Is there a way to reset the firewall tables to their pristine state? If so, that could be worth a try.

    Another thought that occurred to me is that is may have something to do with Filevault disk encryption. My disk is encrypted. Do any of you experience this connection problem have their disk encrypted?

    Just trying to trouble-shoot here.
     
  11. metier macrumors member

    Joined:
    Feb 20, 2012
    Location:
    Texas
    #11
    All 3 of my machines are encrypted with FileVault, and no problems
     
  12. TookiTheGreat macrumors newbie

    Joined:
    Oct 25, 2013
    #12
    Cisco Anyconnect stopped working for me too

    OK. So we can rule out FileVault encryption. Does anyone know how to reset the firewall rules to their pristine state? Turning the firewall off and on doesn't have any effect.
     
  13. metier macrumors member

    Joined:
    Feb 20, 2012
    Location:
    Texas
    #13
    I just turned on the Mac firewall still no problems with anyconnect. A year so ago I had a customer having something similar to this issue, how I solved it was (they were connecting to an ASA) just had then in their browser, browse to the Cisco ASA and connect and login which launched the the anyconnect client and it worked. After they did this they were able to connect with just the anyconnect client again
     
  14. SteveG0 macrumors newbie

    Joined:
    Oct 17, 2013
    #14
  15. TookiTheGreat macrumors newbie

    Joined:
    Oct 25, 2013
    #15
    Cisco Annyconnect no longer works under Mavericks

    Yes! That solved the problem. Thanks for posting this. You are awesome!

    Bard
     

Share This Page