Cisco RV042 Issue with Macs

Discussion in 'Mac OS X Server, Xserve, and Networking' started by beefish, Feb 25, 2011.

  1. beefish macrumors newbie

    Dec 30, 2009
    So Cal
    We have discovered an issue using the latest firmware for the Cisco RV042 Router and Mac OX S. The firmware they had as most recent is would cause web pages to hang, slow email loading and images on websites to not load when using a Mac. PC's running Windows had no issues. Cisco has just put their older firmware version back up on the support page so that it is possible to downgrade to the version firmware that has no issues with Macs in this regard.
    We have been working with Cisco for the last week and they are working on a possible fix. In the meantime, anyone using a Mac and the RV042 should make sure they are using the firmware if they have having similar issues.
  2. belvdr macrumors 603

    Aug 15, 2005
    No longer logging into MR
    Weird. I haven't seen a firmware that impacts a specific OS. Both versions are still available on as well as v4.0.0.7. Have you tried this version, assuming you have Rev3 hardware?

    Also, what made you decide to upgrade? was released in 2009, so it seems strange to suddenly jump up to that version in 2011.

    EDIT: I found this:

    Try manually setting the MTU to 1500.
  3. exabytes18 macrumors 6502

    Jun 14, 2006
    Suburb of Chicago
    With the problematic firmware, did refreshing the websites cause the images to eventually load properly? This sounds like a problem I had with a RV042 and some windows boxes. I didn't have time to screw with it and instead swapped it with a known working router.
  4. beefish thread starter macrumors newbie

    Dec 30, 2009
    So Cal
    Sorry for the delay

    Blvdr - sorry for the delay in responding.

    We have not bothered to look beyond the initial "fix" since both Macs and PCs are working very well now. Cisco told us they would contact us when they had a real fix via a firmware update. Perhaps that is what the 4. is.?.
    (Until we ran into this problem Cisco did not list the older version on the site and last I looked there wasn't the 4). Maybe we will try that. We are waiting for the EnGenius new WAPs to come out in the Fall before we make any changes. "Don't fix it if it works"......unless you are extremely curious and enjoy tinkering. Hmmm:)
    Interesting thread on Cisco's site. and yes we tried setting the MTU to 1500 first.

Share This Page