Cisco VPN + HTTP Proxy but still No Wi-Fi

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Fiallo1984, Jul 14, 2008.

  1. Fiallo1984 macrumors newbie

    Joined:
    Jul 10, 2007
    #1
    In trying to set up my Wi-Fi connection settings, I've run into a bit of a brick wall. My school uses a Cisco VPN with both an account/password and a group/secret system as well as a web proxy server. I've managed to input all the correct IPsec Cisco VPN configurations into my iPhone and received the normal VPN client banner that I receive when I connect using my MBP. With this, I'm able to cruise all the intranet pages of our campus network without inputing any additional proxy information.

    Now comes the frustrating part. In order to cruise the rest of the internet on campus, IT requires an http proxy. After inputing the web proxy settings and the port numbers provided by the IT department into the HTTP Proxy>Manual settings of the desired SSID, my Wi-Fi connection goes from a full 3 bars to no bars in terms of signal strength, my connection peters out even when trying to load intranet pages, and I still can't connect to external internet pages.

    Any hints or suggestions?
     
  2. ShinyToy macrumors newbie

    Joined:
    Jan 16, 2008
    #2
    I'm having a similar problem. My connection doesn't drop out but I can't get any external pages. I'm not sure what the problem is. The VPN info all seems correct and I've tried both using a proxy.pac file and manual proxy config. :confused:

    It sure would be good to be able to use the school internet!!!
     
  3. farsinsen macrumors newbie

    Joined:
    Jul 15, 2008
    #3
    No proxy support for iPhone on VPN?

    +1 ... I'm experiencing the exact same problem.

    When logged on via VPN (Cisco IPSec) Safari does not seem to care about the proxy settings for the current WLAN. I haven't tried using a proxy while not logged on via VPN (as I don't have such a setup at hand), so I cant say if proxy support is broken in general. I've tried pretty much any possible combination of IP's, local hostnames, full hostnames (including FQDN) and a proxy.pac to no avail.

    Anyone have any ideas?
     
  4. ShinyToy macrumors newbie

    Joined:
    Jan 16, 2008
    #4
    With a little troubleshooting i've figured out that the VPN is working fine, but the proxy settings are being ignored. I'm also not sure if proxy settings work properly on the iPhone without VPN but they certainly aren't working with cisco VPN turned on!

    :(
     
  5. ShinyToy macrumors newbie

    Joined:
    Jan 16, 2008
    #5
    I've posted it as a bug here. You guys should reply to it so it will get marked officially as a bug.
     
  6. dshack macrumors newbie

    Joined:
    Oct 6, 2008
    #6
    still no fix, eh? dag, I really want on-campus internetz
     

Share This Page