Cisco VPN on 10.8 Mountain Lion

Discussion in 'OS X Mountain Lion (10.8)' started by Ripmax2000, Jul 26, 2012.

  1. Ripmax2000 macrumors regular

    Joined:
    Aug 31, 2005
    #1
    Does anyone know how well the built in Cisco VPN works now in 10.8?

    In Lion, the built in one would cut out every 45 mins (can't remember exact figure). Cisco's own VPN app works, but you have to run the kernel in 32-bit mode.

    My understanding is there is no 32-bit mode anymore, so I'm hoping Apple have fixed the issue (or that Cisco have released a 64-bit version of Anytime).

    Does anyone have any insight on this?
     
  2. mwhities macrumors 6502a

    Joined:
    Jul 13, 2011
    Location:
    Mississippi
    #2
    Are you referring to the "Add VPN" in the Network Preferences?

    I have been connecting to three different VPNs (Cisco IPSec) with no issues at all.
     
  3. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #3
    It depends on how the ASA is configured at the other end. If the VPN has multiple subnets defined for the server end of the VPN the first pair of IPSec SAs will always form successfully via the Apple built in VPN client, but subsequent SAs may not. This wasn't ever a problem on the Cisco branded client.

    If you only have a small environment and can represent your entire network with one address space do so, then limit down as required by applying ACLs upon authentication.

    What I can't tell you is whether it's fixed in 10.8 though, as everything I now look after has moved over to SSL-based AnyConnect.
     
  4. vom macrumors newbie

    Joined:
    Jul 20, 2011
    #4
    The 'original' Cisco VPN client sucks (unless you are on 32 bit windows). I ran Linux for years and every kernel it got harder and harder and more patches to get it working. Took them forever for 64-bit Windows version. Never even tried Mac version. Stay away from that if possible.

    AnyConnect is certainly the future. This means you have a nice up to date ASA with SSL VPN licenses though.

    For good ole 'Cisco' ipsec VPN - I use the OSX built in VPN. Worked fine for me in Lion and now in ML as well.

    Disconnecting every 45 min or so sounds like perhaps a firewall/router issue ? If your router is deciding to 'tear down' the NAT-T UDP connection (which is an oxymoron anyway - UDP 'connection' that is) - that could be the issue.

    Do you have a friend or relative's network you could try out and see how long you stay connected ?
     
  5. Ripmax2000 thread starter macrumors regular

    Joined:
    Aug 31, 2005
    #5
  6. 0MSA0 macrumors newbie

    Joined:
    Aug 21, 2012
    #6
    Cisco VPN on 10.8 Mountain Lion

    Dear All,

    I Still need to still using my Cisco VPN in ML 10.8, I can't change to native ML because I receive a file with all pw's from networking team.

    Can anyone Help me ?

    Regards

    0MSA0
     
  7. b0rg macrumors member

    Joined:
    Oct 5, 2009
    #7
  8. throttlemeister macrumors 6502a

    Joined:
    Mar 31, 2009
    Location:
    Netherlands
    #8
    The old client may be crap, but the one good thing it does is that it allows to set up a VPN over tcp:443. AnyConnect and the built in client use a whole boatload of different ports. On my client site, I only have access to ports 80 and 443, everything else is dropped at the firewall, so I am essentially forced to use Parallels and the Windows client to connect to my company VPN.:mad:
     
  9. bogatyr macrumors 65816

    Joined:
    Mar 13, 2012
    #9
    I've had no issues staying on for more than 45minutes using Lion or ML's client. I also have no issues with multiple subnets. Are you sure it is a client issue?
     
  10. Ripmax2000 thread starter macrumors regular

    Joined:
    Aug 31, 2005
    #10
    Yes, tried the VPN in ML and getting the same exact issue. The Console error says:
    configd[16]: IPSec Controller: XAuth reauthentication dialog required, so connection aborted
     
  11. crucius macrumors regular

    Joined:
    Apr 4, 2010
    Location:
    Portugal
    #11
    in my case i want to access my university privileges through vpn

    while on Lion, i could access it without problems through Cisco VPN client, but now on ML i can't use it anymore because 32-bit apps are not supported

    i configured the native VPN, but i always get a "configuration error" (i followed instructions from this link: http://anders.com/guides/native-cisco-vpn-on-mac-os-x/ but i don't have the racoon process running...)


    what's happening? i can do it without any problems on windows...
     
  12. JaxDroidGuy macrumors newbie

    Joined:
    Mar 12, 2013
    #12
    Many thanks for this!

    I just bought my first Mac (MBP 13) and really needed to get the VPN going for work. For some reason my XP VM isn't connecting like it does from my Linux box (need to do some research). I actually prefer to run in the VM so my primary internet connection is still available.

    In the interim, at least, this is working like a champ! I've already connected a couple of times (much faster than the Cisco client btw). Thanks again!

    One question: is there a video setting to get it to fill the screen? Full screen still has borders on the left and right so I lose a little real estate.
     
  13. Kuwait macrumors member

    Kuwait

    Joined:
    Apr 25, 2012
    Location:
    Kuwait
  14. JaxDroidGuy macrumors newbie

    Joined:
    Mar 12, 2013
  15. aaarrrgggh macrumors regular

    Joined:
    Jul 1, 2007
    #15
    Not fixed

    Not fixed in 10.8. Thanks for the explanation, was banging head against wall.

    For those that don't understand the original post, as I understand it, if the LAN you are connecting do has different subnets for local resources and VPN clients you are out of luck.
     

Share This Page