OS X Civ 5 retina resolution - all text/artwork pixelated

juliancs

macrumors 6502
Original poster
Aug 24, 2006
419
1
Using the latest version on steam. The HdPi resolutions are there and I'm on them. In game assets look crisp but the menu/overlay/text is all pixelated. Enough to make it distracting. I've searched the net but not found anyone with an actual solution. Any ideas?
 

cruisin

macrumors 6502a
Apr 1, 2014
962
223
Canada
Are you on the default resolution on the desktop? This website suggests changing the desktop to a higher scaled resolution before starting the game.
 
Comment

juliancs

macrumors 6502
Original poster
Aug 24, 2006
419
1
Are you on the default resolution on the desktop? This website suggests changing the desktop to a higher scaled resolution before starting the game.
Hey Cruisin,

Thanks for your reply. I should have mentioned, I've tried it will all desktop resolutions. I'm normally using the computer in-between the "Best" and "More Space" setting. No Luck!
 
Comment

AspyrSupport

macrumors newbie
May 28, 2014
11
0
Civ 5 retina resolution - all text/artwork pixelated

Hey Juliancs, if you have the retina MBP with the dual chipset, deselect the automatic graphic switching option in your System Preferences/Energy Saver menu.

Then, move the resolution all the way over to the 'More Space' option and relaunch the game.

After that, if you're still running into the problem, open a support ticket with us. Support@aspyr.com.
 
Comment

ErikGrim

macrumors 601
Jun 20, 2003
4,448
3,018
Brisbane, Australia
Hey. What's the best way of playing it on the 5K iMac? No built in resolution for native 5120x2880, and the highest HiDPI setting makes all the UI pixellated indeed. Even with the Display Slider set to More Space (which still only goes to 3200x1800??) everything is an oversized pixellated mess.

Is there a settings file I can manually input resolution into?
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.