Civ V on 2011 MBP?

Discussion in 'Mac and PC Games' started by evandy, Jun 25, 2011.

  1. evandy macrumors newbie

    Feb 5, 2008
    Has anyone been able to get Civ V running on the current-gen 15" MBP? I just got a new 15" 2GHz Coer i7 since my toddler washed my old laptop, and Civ V crashes right after the intro movie. I have tried both integrated and discrete graphics thanks to gfxCardStatus, but I can't get to the start-a-game screen.

    Aspyr suggested setting graphics to Intel-only via System preferences, which is of course impossible. But gfxCardStatus will do that, and it isn't a help. Per their recommendation, I tried deleting the .plist file before/after switching as well.

    Crash report attached.

    Attached Files:

  2. doh123 macrumors 65816

    Dec 28, 2009
    works fine on my 17" with the HD 3000 and with the 6750 ... I don't have access to one with the lower end 6490 if thats the GPU you have in your 15.

    The HD 3000 doesn't work right if you don't have the latest patch for Civ5, but it didn't crash with the older version, it just didn't have text.

Share This Page