Civilization IV Graphic Problems

Discussion in 'Mac and PC Games' started by jbyun04, Jul 5, 2010.

  1. jbyun04 macrumors 6502a


    Aug 31, 2008
    I just got Civ IV complete off Steam for $10 yesterday (totally worth it) but I'm having a problem where the 3d portraits don't show up other than maybe 5% detail of the accessory the model is wearing and also after playing about 2 hours the map starts get black boxes everywhere.

    Any ideas?

    I'm running it in clamshell mode (9600m) on 1920x1080 on medium settings.
  2. ayeying macrumors 601


    Dec 5, 2007
    Yay Area, CA
    Try reinstalling the game. I don't have that issue on my Core Duo MacBook Pro with a X1600 video card. I run it at all High @ 1680x1050 in clamshell.
  3. Ainze macrumors regular


    Feb 28, 2010
    From what I've heard, this is a common problem, with both the steam version and boxed version from Aspyr. I know I've been getting it too. Funny thing is that I can run the PC version in Mac OS with wine and get none of those bugs (and less heat!). Makes me wonder if it was worth it. Anyway, if there is a fix, I haven't found it. :(
  4. Venkman90 macrumors regular

    Aug 3, 2009
    I run the Steam version fine on my 9400m

    Have you tried turning of AA? I heard that helps...
  5. jan08 macrumors regular

    Oct 20, 2006
    Wakefield, England
    I get the black boxes as well, but zooming out and then back in seems to clear it no problem. Terrible screen tear issues as well on my iMac i5.
  6. Panch0 macrumors 6502a

    Feb 23, 2010
    Civ4 Graphics issues

    I've had issues with the leader heads only showing a few layers, like a skull with eyeballs but no skin - creepy - and black boxes displaying where the cities should be. This is on a late 2008 MBP with 9400 or 9600 nVidia graphics. I haven't seen the issues on my new iMac i7 with ATI Graphics or my older iMac core duo with ATI 1600, so IMO there's an issue between Civ4 and the nVidia drivers.

    As someone mentioned, zooming to globe view then zooming back in seems to clear the black boxes. For the leader heads, I found a module called "Static Leader Heads" that replaces the animated leaders with a simple picture. Static Leader Heads is more a work around than a solution, but I liked it better than seeing disembodied eyebrows blinking at me...
  7. AoxomoxoA macrumors member

    Apr 8, 2010
    Go into the video options...

    Advanced>Options .. click on the graphics tab...

    then change the anti-aliasing MultiSamples to 0.

    Restart the game for changes to take effect.

    That should fix the issue.

  8. BertyBoy macrumors 6502

    Feb 1, 2009
    Same solution worked for me years ago with the boxed verson, turn off anti-aliasing.

    And I only tried it after I had video issues in another game which were fixed by doing this too.

Share This Page