Clamshell mode (disabled internal display) in Mavericks?

Discussion in 'OS X Mavericks (10.9)' started by jackeill, Jul 6, 2013.

  1. jackeill macrumors member

    May 2, 2010
    Does Mavericks, along with new multi-display features, let user work in clamshell mode? I really need clean and easy way to work only on my external display with internal one being disabled (closed or opened). I could achieve that with some hacks (waking up from external keyboard) before Lion. Since Lion it is very hard to achieve. Even using terminal commands is not working for me in 10.8.4.
  2. AAPLGeek macrumors regular

    Nov 12, 2009
    I believe there was a thread where someone mentioned the the sudo args command restored that functionality in Mavericks.

    Apple yanked the opened internal display behaviour post 10.8.1.
  3. ctransch macrumors newbie

    Sep 24, 2012
    I use mine with a Thunderbolt display at the office. I have my external keyboard, mouse, and drives plugged in to the display. Arriving at the office I only attach the power and thunderbolt cables on my rMBP.

    It works 95% of the time. Occasionally I've had to unhook it and reattach it to get the USB speakers in the display to come on.
  4. JackZen macrumors newbie

    Jul 4, 2013
    you can achieve this by putting a small piece of magnet near the headphone hole.(mc700 is ok for this, some macbook is near the right bottom.):eek:
  5. Watabou macrumors 68040


    Feb 10, 2008
    United States
    I got it working for me in Mavericks with internal display closed (really closed, not just sleeping), but with the lid open (or closed, stays shut either way)

    Here's what I did:

    1. Enter this into the terminal:
    sudo nvram boot-args="iog=0x0"
    2. Restart
    3. Log in.
    4. Connect a bluetooth device like a mouse.
    5. Close the lid. The external display should power off too.
    6. Move the mouse. This should wake up the external display but not the internal one.
    7. Voila. The internal display stays shut even when you open the lid, while the external display keeps running.

    I use this because my aging Macbook Pro's display doesn't work anymore so I don't want the graphics card powering it up along with the external one. I've noticed that this approach significantly reduces the temperature compared to when the GPU was having to power up both displays and the fans were at 6000rpm nonstop, even when I wasn't doing anything. They are nice and quiet now.

    To undo the terminal command, just zap the PRAM. :)
  6. jackeill thread starter macrumors member

    May 2, 2010
    Yes, I know that I can do this when I spend 5 minutes or so on closing/opening the lid and waking up/powering on the Mac. Most of the times though it just goes to sleep back again, whatever I do. It is a pain.

    Could anyone of developers make such a feature request (or a bug report, as for me it is clearly a bug)? Generic ability to disable any of the displays (internal or external) would be awesome - for other purposes, too.
  7. serchq macrumors newbie

    Nov 5, 2013

    Tanks!!! It works great for my MBP late 2011
  8. radiohead14 macrumors 6502a

    Nov 6, 2008
    was just about to ask this same question when i saw this thread. any updates on this?

    i double boot windows 8.1 and this is a feature there. you have the option to show only the external, and it even remembers your selection automatically the next time you plug in.
  9. Sumleilmus macrumors member


    Nov 6, 2011
    But I want to use my MagicTrackpad and internal keyboard

    If both displays are active, using Screen Sharing from the LAN (or WAN) is disagreeable at best, as both displays will appear on the display of the remote client.

    Also, some, such as me, want to use their wonderful internal keyboard and Magic Trackpad with an external display.

    The magnet trick turns off not only the internal display, but also the internal keyboard and Magic Trackpad.
  10. wacks macrumors newbie

    Sep 5, 2014
    so i typed this sudo command in and now my laptop doesn't recognize my external display at all. i try to connect and disconnect, close my mac's screen etc but nothing shows up on my external display. the only time anything shows up is if i unplug the hdmi to dvi adapter i'm using from my mac for a split second there's a flash of my screen on the external display but it goes away in a flash and then agin, nothing shows up.

    how do i undo this sudo command?

  11. Watabou macrumors 68040


    Feb 10, 2008
    United States

    As stated in my post, zap the PRAM.

Share This Page