Clamshell mode with open lid

Discussion in 'OS X Yosemite (10.10)' started by The Unseen, Aug 1, 2014.

  1. The Unseen macrumors member

    The Unseen

    Joined:
    Jun 24, 2012
    Location:
    Naples, Italy
    #1
    Hi to all, I have a Late 2011 MBP.
    With Mountain Lion and Mavericks, I found a method to use the Mac with only the external display but keeping the trackpad, the keyboard and the iSight active.

    With Mountain Lion, I've used This method :




    With Mavericks, I did the same by :

    1)Installing "Nosleep"
    2)Activating it
    3)Putting a magneto on the right place to switch off the internal display
    4)Opening The System Preferences on the "Displays" section
    5)Pushing "Alt" to change the button in "Detect Displays"
    6)Clicking on "Detect Displays"
    7)Removing the magneto.

    Now sadly this methods don't work in Mac OS X 10.10 PB1, I would like to know if there is anyone that knows if there is a way to work with only the external display on, and with trackpad, keyboard and iSight usable.
     
  2. CaffeinatedNoms macrumors member

    CaffeinatedNoms

    Joined:
    Jun 8, 2014
    Location:
    Northeast England
    #2
    I so hope you mean magnet, not magneto; kilovolt power supplies are nasty beasts.

    From my observations over the past week, Yosemite seems to handle sleep a little differently on my 2011 MBP than Mavericks did, which could explain why you can't just force it to assume the display is off when a magnet is present.

    I'm guessing that now the system is designed to go "I am clamshell, I will sleep now" rather than "I am clamshell, I will turn off the display and sleep when I'm good and ready" like it used to.
     
  3. The Unseen thread starter macrumors member

    The Unseen

    Joined:
    Jun 24, 2012
    Location:
    Naples, Italy
    #3
    Yes, I mean magnet :D , english is not my primary language

    Anyway, I am keeping the internal display off with the magnet , but I cannot use the trackpad (that is what I would like to do).
    If I remove the magnet, the Mac newly detects the displays and switch the internal display on.
     
  4. CaffeinatedNoms macrumors member

    CaffeinatedNoms

    Joined:
    Jun 8, 2014
    Location:
    Northeast England
    #4
    Just out of curiosity, why is it that you would rather work with the one display rather than two? Unless you're playing heavy games, or extremely low on desk space, I can't think of a reason why two displays would be worse :p

    I've just tried playing with a small magnet on the side of my 2011MBP and I'm experiencing the same as you say, which does suggest they've changed the nature of the sleep/wake on lid action. Looks like you'll have to find another work around!

    Also I'm greatly amused by the mental image of using magnetos as a method of automatically opening and shutting a MacBook lid. At 36,000rpm. SLAM! :D
     
  5. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #5
    I can't speak for the OP but I absolutely hate using 2 displays if they're not identical models lined up perfectly next to each other.

    If that's not the setup then I'll absolutely turn off the smaller screen and ignore it.

    (The ONLY exception to this is if I'm video editing and using the 2nd mis-sized screen as a full-screen video monitor. That's fine. But if it has any computer UI on it, not a chance.)
     
  6. The Unseen thread starter macrumors member

    The Unseen

    Joined:
    Jun 24, 2012
    Location:
    Naples, Italy
    #6
    I like to work with two displays in certain situations (for example, when I have to compare images for websites, or when I have to manage a large number of apps open at the same time), but normally I prefer to work with only one display because the temperatures are lower, the performance is slightly better, and in the long term the internal LCD will last longer in good shape.

    :D:D:D Yes so do I, unintentional funniness sometimes is the best!!!!
     
  7. mrnoglue macrumors member

    Joined:
    Jul 14, 2011
    #7
    You can turn the brightness of the internal display down to zero.

    Not a perfect fix, but should work for now.
     
  8. The Unseen thread starter macrumors member

    The Unseen

    Joined:
    Jun 24, 2012
    Location:
    Naples, Italy
    #8
    I know, but it can be only a temporary solution for me: switching down is a completely different game.
    For now I will continue to put the little magnet at the left of the keyboard, under the speaker, to keep the internal display switched off. But I miss the trackpad!!

    Anyway thank you
     
  9. lolasher macrumors newbie

    Joined:
    Aug 1, 2014
    #9
    Try this
    Code:
    sudo nvram boot-args="kext-dev-mode=1"
    Then reinstall NoSleep. It's the same trick used to enable trim on 3rd party SSD drives.
     
  10. The Unseen thread starter macrumors member

    The Unseen

    Joined:
    Jun 24, 2012
    Location:
    Naples, Italy
    #10
    Thank You, but no luck.
     
  11. lolasher macrumors newbie

    Joined:
    Aug 1, 2014
    #11
    I forgot to tell that you should reboot after that command.
     
  12. The Unseen thread starter macrumors member

    The Unseen

    Joined:
    Jun 24, 2012
    Location:
    Naples, Italy
    #12
    yes, I've done a reboot, but nothing changed.

    I believe the reason is that, applying the "Mavericks" method, in the moment I remove the magnet, the Mac newly detect the displays. Under Mavericks it didn't happen
     
  13. lolasher macrumors newbie

    Joined:
    Aug 1, 2014
    #13
    I guess we have to wait until NoSleep update, I tried to use it for long downloads, but I had issues with WiFi.
     

Share This Page