Classic Environment not Supported??

Discussion in 'Mac Basics and Help' started by beanisme, Jul 3, 2008.

  1. beanisme macrumors newbie

    Joined:
    Jun 14, 2008
    #1
    hi, i new to using mac. recently i try opening a file but when i double click the file, it says that ' classic environment ' is no longer support.

    i have no idea what it means.. can anyone help? i need to open the file.. My macbook is running on mac os x 10.5.4
     
  2. soberbrain macrumors 65816

    soberbrain

    Joined:
    May 9, 2008
    #2
    Leopard 10.5 cannot open apps that were made for OS 9 and below.

    I needed to do the same thing, luckily I had an old copy of Tiger 10.4 which has classic support. I installed Tiger on an external drive to open up the file.
     
  3. PLin macrumors 6502

    Joined:
    Oct 9, 2003
    #3
    What kind of file is it? The classic environment was for non-Intel Macs to run software written for Mac OS 9 when the computer was booted into Mac OS X.

    Even if you could run Tiger, the classic environment won't run on a MacBook anyway.
     
  4. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #4
    Not completely correct, you have to have a copy of OS 9 installed, Tiger doesn't just open up classic files.
     
  5. beanisme thread starter macrumors newbie

    Joined:
    Jun 14, 2008
    #5
    okok/\.. i found an altenative anyway.. thks for the help:)
     
  6. jshah5115 macrumors newbie

    Joined:
    Feb 14, 2008
    #6
    Post your alternative please

    Hello,

    I'm trying to run some older software on my macbook as well and would like to know what your alternative solution was. I (as well as others) maybe able to benefit from it.

    Thanks!

    J
     
  7. Duff-Man macrumors 68030

    Duff-Man

    Joined:
    Dec 26, 2002
    Location:
    Albuquerque, NM
    #7
    Duff-Man says...what exactly are you trying to do? The person above was looking to *open a file* - not run a program. If I were to guess they probably just found another newer pgm that would open the file they had. If you are trying to run an actual OS 9 (or earlier) program then you'd best look to find a native OS X alternative....oh yeah!
     
  8. jshah5115 macrumors newbie

    Joined:
    Feb 14, 2008
    #8
    So I'm studying for the an exam that's given yearly for orthopedic surgery residents, and every year's exam is released on a CD and the CDs before 2005 all give me this error. I was wondering if there was a work-around. I'm trying to run them on a penryn macbook with OS 10.5.4, this is my first mac so unfortunately I don't have any previous versions of the os in my possession. Any help is greatly appreicated, thanks!

    J
     
  9. Seananigans macrumors newbie

    Joined:
    Mar 26, 2010
    #9
    I'm trying to get my wireless internet to work with MTS. They sent me the modem and a 'D-Link DFE-690TXD 32-bit PC Card'. Now, I was following the instructions in the 'Quick Installation Guide' which involves firstly inserting the Driver CD, then it tells me to copy a folder to my desktop and from there open the installer, however when I try to do that it gives me a message saying I cannot open the installer application because the "classic environment is no longer supported." Any clues on how I can make this work? I'm running a MAC OS X Ver. 10.6.2
     
  10. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #10
    If your device needs a driver and doesn't work out of the box, then you'll need to look on the manufacturer's site. There's no way that an OS 9 driver will work on OS X, whether you have Classic or not.

    Edit: This might be what you need.

    Edit 2: Although I question why you're using that card in the first place when your computer already has an Ethernet port :confused:
     
  11. BrokerDon macrumors newbie

    Joined:
    Sep 6, 2006
    #11
    DFE-690TXD vs. OS X 10.4 "Tiger"

    I've got EXACTLY the same problem with my D-Link DFE-690TXD 10/100Mbps Ethernet CardBus adaptor in my PowerBook G4 Ti. D-Link email Tech Support has been useless... They said to use the version 5.00 installer but:

    1. the OS X v5.00 DFE-690TXD "Installer" included in D-Link's download ISN'T an OS X installer (it opens in TextEdit)
    2. my DFE-690TXD has different XXXX,YYYY numbers which I figured out how to modify in the 690TXD file they includeed in spite of D-Link's broken links to a resource editor that can make these mods. The trick was to Google and download the OLDER v1.XX resource mod app to follow D-Link's instructions since the commands they say to follow don't follow with v2.XX of this app
    3. they now want me to pay for Tech Support to get their installer to in OS X (it works PERFECTLY in OS 9.2.2). I'm not that desparate yet so let me know if you figure out how to get it to work in OS 10.4 "Tiger" so I can use this card's MUCH faster 100Mbps Ethernet when connecting to our 100% Gigabit LAN

    Thanks!
     
  12. techy298 macrumors newbie

    Joined:
    May 2, 2011
    #12
    Classic Environment Question

    Ok, I got my hands on a "file" that when I try to launch it shows

    [​IMG]

    What do I need to open it?

    I can try it on an iMac running 10.4, is that my only option?
     
  13. mrkramer macrumors 603

    mrkramer

    Joined:
    Jul 11, 2006
    Location:
    Somewhere
    #13
    That is probably your best option, just make sure the iMac is PPC and not intel. If you only have access to intel macs, you can try looking for an older Mac that is running OS 9 if you know anyone who has had macs for a long time they might have one sitting around in a garage or closet that you can use.
     
  14. aneomon macrumors newbie

    Joined:
    Sep 27, 2011
    #14
    I'm currently running on a Macbook Pro version 10.6, I tried to run a game on my computer but it said that my Mac cannot run OS 9 because the Classic environment is no longer supported. Is there any way I can get around this on my computer, or do I have to return the game?
     
  15. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #15
    There is a way around this but it's complicated, and doesn't work on 10.7 (Lion). Also, not all apps written for Mac OS 9 work properly in this environment - games seem to give me the most trouble, sadly.
     
  16. goonie.grrl macrumors newbie

    Joined:
    Dec 17, 2011
    #16
    Any and All Advice/Help Welcome

    I'm experiencing the same dilemma described by others related to an outdated game I cannot open on my MacBook Pro (system configuration: 2.6 Ghz, Intel C2D, running OS X Leopard 10.5.8): Here are my specifics: Became addicted to the game "MaciGame," which I discovered on an old Mac given to me for free at a yard sale (one of the large "color" iMacs, running OS 9). This old Mac just died.... (I believe something electrical: it makes no response when power button is pressed, and prior to this when using the machine it would make snap-crackle-pop and electrical zap! noises with "static" sounds popping all over the screen/housing at which times the screen would zap! out and go "dead"/black then return dimly with a jumpy glitch, stabilize, and very slowly increase in brightness; the longer the system was on the more frequently this would occur, until on some occasions it would ultimately shut itself down/power off completely, which is what occurred the last time it was running.) I finally found a download link for MaciGame 2.17 on cNet (the game was shareware or freeware), downloaded it, and was unable to open it, receiving the same error message as others regarding "the Classic Environment [being] no longer supported." So, my inquiry to wrldwzrd89 is this: You said there is a way around this problem, though it is difficult and most problematic for games; Is this something you could walk me through and that might possibly work for me? This particular game is very simple, 2D, comprised of a matrix of colored dots on which you click and double-click. If that is not an option for me, then my inquiry goes back out to any and all, as such: My second thought is to remove the hard drive from the old iMac, house it, and connect it to my MacBook Pro as an external hard drive/slave drive, but my questions are (1) whether the hard drive is even salvageable/usable given the current state of the iMac (could the hard drive have been the cause of OR have been damaged by the (seemingly electrical) problem(s) with the system and ultimate system failure?), (2) would my MacBook Pro be able to read and run the contents of the iMac/OS 9 hard drive? Any and all helpful thoughts, advice, or comments are appreciated!
     

Share This Page