Classic Mac OS on Unsupported Machines

Discussion in 'PowerPC Macs' started by iMacC2D, Dec 6, 2014.

  1. iMacC2D, Dec 6, 2014
    Last edited: Aug 12, 2017
  2. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #2
    Someone was mentioning this in IRC the other day. I'm VERY tempted to try it out on my iMac G4!
     
  3. LightBulbFun macrumors 6502a

    LightBulbFun

    Joined:
    Nov 17, 2013
    Location:
    London UK
    #3
    I have to say WOW very well done looks like its coming along nicely I will have to try this on my iBook G4 (late 2004 1.33Ghz 14.1 inch) But that has 7447A PPC G4 which I hear can not boot into OS 9? I did get my 1.42GHz FW800 MDD Booting OS9 via the firmware downgrade way while that works my Air port extreme slot no longer works in OS X or 9 LOL if this way works on FW800 MDDs then I need to find away to go back to the original firmware LOL I wonder if this can Also be used to boot OS 9 in QEMU?
     
  4. iMacC2D, Dec 6, 2014
    Last edited: Aug 12, 2017

    iMacC2D thread starter macrumors 6502a

    Joined:
    Jun 24, 2010
  5. bse5150 macrumors 6502

    bse5150

    Joined:
    Jan 12, 2014
    #5
    MacRumors has an IRC channel?
     
  6. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #6
  7. bunnspecial macrumors 603

    bunnspecial

    Joined:
    May 3, 2014
    Location:
    Kentucky
    #7
    Thanks for the hard work and for writing all of it up.

    I'm going to try later today on my iMac, and if that is successful I may even attempt it on my DLSD Powerbook. I think those are the only working G4s I have at the moment that don't boot into OS 9, although I have a FW800 MDD sitting in my closet that waiting for me to get a chance to work on it.
     
  8. weckart macrumors 68040

    Joined:
    Nov 7, 2004
    #8
    Tried on my 1GHz iMac G4 and it boots up in 256 colours. Unfortunately, no OS9 drivers on the HD so it cannot see it.

    No amount of tinkering with OF will allow me to boot on a 12" iBook 1.33Ghz. It can see the volume as bootable but gets stuck on a grey screen immediately.
     
  9. LightBulbFun macrumors 6502a

    LightBulbFun

    Joined:
    Nov 17, 2013
    Location:
    London UK
    #9
    got it working

    Just wanted to report that I got the ROM from ThinkClassic and did the OF commands and I was able to boot OS 9 on my 7447A G4 iBook :D. the hard drive was dead in the iBook so i had my G4 MDD FW800 in TDM. every thing worked (sound battery etc) apart from the graphics card which has the phantom display problem can some one give me the right files to fix it? bellow are some pics (I think i'm the first to boot OS 9 on a non OS9 7447A mac correct me if i'm wrong :eek: )
     

    Attached Files:

  10. PowerMac G4 MDD macrumors 68000

    PowerMac G4 MDD

    Joined:
    Jul 13, 2014
    Location:
    At the intersection of Conch and Coral.
    #10
    Man, this is unheard of and very cool! (and to think it hasn't necessarily been done/documented before). It would be hilarious to show this to Apple... I bet the first thing they would be surprised at is how they weren't able to remove everyone from their PowerPC Macs!
     
  11. iMacC2D, Dec 7, 2014
    Last edited: Aug 12, 2017

    iMacC2D thread starter macrumors 6502a

    Joined:
    Jun 24, 2010
  12. LightBulbFun macrumors 6502a

    LightBulbFun

    Joined:
    Nov 17, 2013
    Location:
    London UK
    #12
    Just checked it now and Yeah its exactly the same as your picture. if it means any thing I remember the flashed 128MB R9200 AGP card in my G4s would have no acceleration under OS 9 I would get an X on the acceleration extension during booting signifying its not loading I would also get a phantom 640x480 second display on it (sawtooth or MDD it didn't change it)
     
  13. supernova777 macrumors member

    Joined:
    Dec 22, 2007
    #13
    congrats lightbulb + kudos to imic;) :apple:

    ----------

    which version of mac os 9 were u running using a 9200 is only possible i think if u are using the very latest 9.22 system extension versions
    u can read more about that on macos9lives.com forum by doing a search for '9200' we had a user who for the life of him couldnt get his 9200 to work after he used a customized os9 install made by our users he was up + running
     
  14. LightBulbFun macrumors 6502a

    LightBulbFun

    Joined:
    Nov 17, 2013
    Location:
    London UK
    #14
    Thanks, I am Using a OS 9 image from mac os 9 lives the one General MDD one (I did some looking and I know my R9200 is using a 64KB reduced ROM now from what I saw the way they Reduced a GPU ROM to 64KB was Lop off some sort of Driver section in ROM I wonder if that was the OS9 part. I have tried a load of different drivers in OS 9 non give me full graphics ) if you have any suggestions let me know LOL
     
  15. iMacC2D, Dec 12, 2014
    Last edited: Aug 12, 2017

    iMacC2D thread starter macrumors 6502a

    Joined:
    Jun 24, 2010
  16. LightBulbFun macrumors 6502a

    LightBulbFun

    Joined:
    Nov 17, 2013
    Location:
    London UK
    #16
    Thanks for the extensions I tried them in my iBook G4 it works nicely I can switch colour and Res Just fine One thing I saw tho is OS 9 uses a Generic CRT icon for my display instead of an iBook one like your one I wonder why that is I will attach some pictures (I also saw the Wifi card dose show up in OS 9s system profiler)
     

    Attached Files:

  17. iMacC2D, Jan 31, 2015
    Last edited: Aug 12, 2017

    iMacC2D thread starter macrumors 6502a

    Joined:
    Jun 24, 2010
  18. agottschling macrumors newbie

    agottschling

    Joined:
    May 11, 2014
    Location:
    Michigan, United States
    #18
    I now have the itch to try this on my G5. Anyone wanna point me in the direction of how to do this?
     
  19. iMacC2D, Feb 7, 2015
    Last edited: Aug 12, 2017

    iMacC2D thread starter macrumors 6502a

    Joined:
    Jun 24, 2010
  20. lukel macrumors newbie

    Joined:
    Oct 13, 2014
    Location:
    London, UK.
    #20
    Thank you for this!

    I installed OS 9 on my MDD dual 1.25 FW 800 and can confirm that it works near perfectly. The only issue that I have encountered is that the G4 wont wake up from sleep. However, this was noted in your original post.
     
  21. sk8er123 macrumors member

    Joined:
    Apr 2, 2012
    Location:
    Cincinnati
    #21
    I successfully installed OS9 on my 17" Powerbook 1.5 Ghz, to my surprise I could get the right resolution after fiddling with the display settings, but I am stuck on 256 Colors.. Is there anyway around this? Also it seems to think I have two displays (?) and display two is listed as Millions of Colors? Thanks
     

Share This Page