Clean 10.9.3, new SSHD, runs externally only

Discussion in 'OS X Mavericks (10.9)' started by donladue, Jun 19, 2014.

  1. donladue macrumors newbie

    Joined:
    Jun 18, 2014
    Location:
    San Francisco
    #1
    I must have screwed up the install. I've read many posts but don't know what to do for my particulars.

    1. I downloaded the "Install Mavericks" application onto the internal Toshiba 500GB, running 10.6.8 (this is a MBP 13" from 2011).

    2. I attached a new Seagate 1TB SSHD using a SATA to USB cable, and formatted it using the 10.6.8 Disk Utility.

    3. I ran the Install Mavericks application, installing to the Seagate, and spent all day installing all of my applications, dbs, docs, etc., on the new drive. Everything was running wonderfully while the Seagate was external.

    4. Replaced the internal Toshiba with the Seagate and started the MBP. Gray screen with question mark. If I inserted the old Apple 10.6.8 CD, it would start to boot, then beep three times.

    5. Swapped back to the Toshiba. Ran "Recovery Partition Creator 3.7" on the Seagate, verified that it can re-boot into recovery by holding down the [Command]-R, as long as the Seagate / Mavericks disk is external.

    6. When I swap the disks again so the Seagate is internal, I get the question mark, it won't boot.

    7. Lather, rinse, repeat. I must have swapped 6-7 times this evening. :confused:

    -----
    Is this fixable without starting over?

    Thanks so much,
    Don
     
  2. donladue thread starter macrumors newbie

    Joined:
    Jun 18, 2014
    Location:
    San Francisco
    #2
    Still doesn't work...

    I did an upgrade install to the internal drive, then reformatted the Seagate via USB cable. Carbon Copy Cloner to move the internal contents to the external drive. Then swapped drives again.

    Still no joy, just the question mark. :confused:

    Any ideas, anyone?

    Thx,
    Don
     
  3. snorkelman macrumors 6502a

    snorkelman

    Joined:
    Oct 25, 2010
    #3
    tried a PRAM reset?
    failing that any reason you cant carry out an install with the seagate as the internal drive (other than the need to start over?)
     
  4. Manic Harmonic macrumors 6502

    Joined:
    Dec 4, 2011
    #4
    The last thing I would try is to make a bootable installer, put the sshd in, and install to it that way. I think you may have gotten a lemon though, things are definitely pointing towards that. If that doesn't work, call Seagate or wherever you bought it from. This really shouldn't happen at all, I've done this same procedure the same way you did and never had this problem.
     
  5. donladue thread starter macrumors newbie

    Joined:
    Jun 18, 2014
    Location:
    San Francisco
    #5
    Finally...

    Hooray. If I took that clamshell back off any more I might be able to do it in my sleep.

    Evidently it was necessary to place the new disk in the computer *first*, removing the original drive, and then boot from the original as an *external* drive.

    If the new drive was outside, the drive formatting just wouldn't stick -- even if it looked good after Disk Utility was through with it. On one of the trials, I also forgot to go to the Partitions tab and create exactly one partition of type GUID. It was insufficient to simply assume that there would be one partition after formatting the drive.

    The other mistake I think I made was to try and combine my two goals: (1) upgrading the disk and (2) upgrading to Mavericks. With the OS on 10.6.8, it may be that you cannot (correctly) create the invisible Recovery partition -- there's some sort of bug in 10.6.x that prevents it. So even if I had tried the first time with the new disk installed, I still would have had to perform the 10.9 upgrade on my existing disk first.

    What I had wanted was a clean install, but that doesn't seem to have been in the cards with the tools at hand.

    I wish Apple could have chipped in for my hours on this upgrade. Imagine all of the booty I could have bought! :) I also hope that this reply will be helpful to others who might find themselves in similar circumstances.

    Thanks MH and Snorkelman for the replies!
    Don
     

Share This Page