Clean Install on a non GUID machine

Discussion in 'OS X Mountain Lion (10.8)' started by shiftlocked, Jul 14, 2012.

  1. shiftlocked macrumors newbie

    Joined:
    Nov 9, 2011
    #1
    Hi All,

    Wonder if anyone could help with this. So I'm trying to install Mountain Lion GM on my iMAC however I get the following error about the target location.

    Off I go to the disk utility but I can't change the MBR type. Seems the only way to go is with a clean install. No problem I think, stuff is all backed up.

    Into disk utility and I try to restore the Mountain Lion DMG to a USB stick but I get invalid argument (im not even sure if restoring a dmg to a usb key would work)

    So at this point I can't format to get things to GUID and unable to create a boot able usb mountain lion usb key (unless I've missed something on the web)

    Please tell me there has to be a better way than looking for my Snow Leopard disks, running disk utility there, formatting drives, installing SL and THEN mountain lion?
     
  2. AlsoKnownAs macrumors member

    Joined:
    Jun 21, 2010
    #2
    Use the the following guide to create a Mountain Lion usb drive:
    http://osxdaily.com/2012/02/17/make-bootable-os-x-10-8-mountain-lion-usb-install-drive/
    Make sure you mount installesd.dmg before restoring to the usb drive or else you will get an error after 10 minutes or so.

    Then boot from the usb drive by holding the option key while booting your Mac. Format your HDD using the GUID partition table and then install Mountain Lion.
     
  3. arashb macrumors 6502

    Joined:
    May 3, 2009
    #3
    Did you get the ML DMG off ***** or is it a developer DMG?
    If it's from ***** then restoring should be okay, I got an error at the very end but the USB was still usable.
    If it's a developer DMG then you have to right click the "Install Mountain Lion" app and click "Show Package Contents" and find "InstallESD.dmg"

    To get your HD into GUID, once in the installer open up Disk Utility and go to your main drive, click on the "Partition" tab and then choose "1 Partition" for the "Partition Layout:" and on the bottom of the layout box you should see a box labeled "Options..." click that and choose GUID.
     
  4. shiftlocked thread starter macrumors newbie

    Joined:
    Nov 9, 2011
    #4
    1 word. ARRGGGHHHH

    Ok. So it's now installed but in a nightmare fashion.

    The restore to the USB stick HAD worked but for some reason my iMAC refused to boot from it, showing the stop sign on each attempt.

    So how did I fix it at 4am in the morning lol.

    1. Boot from a time machine backup
    2. Disk utility, delete all the partitions and then create 3 new partitions
    3. Restore the Mountain Lion Installer into partition 3
    4. Restart, boot from Partition 3
    5. Install

    Some notes.

    InstallESD.dmg doesn't exist in the GM version. Honestly there's no shared folder like all the guides point to. I've shown hidden files and clicked..every...single...folder. If someone knows the path in the GM please share with me :D

    I couldn't make the disk a GUID type till all the partitions were removed and re created. The options box was firmly greyed out till I basically blasted the disk to start from scratch..

    The USB restore had worked despite an invalid argument error as I used the same key on a "normal GUID" macbook pro 2009 with no issues at all.

    Hope this info is usefull for someone out there :)
     
  5. SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #5
    There is if you got ML from the app store. The .dmg file that you sourced elsewhere IS the InstallESD.dmg, someone else has just renamed this - you were actually looking for the InstallESD.dmg file inside InstallESD.dmg...
    :D
     
  6. shiftlocked thread starter macrumors newbie

    Joined:
    Nov 9, 2011
    #6
    Lol. Thanks for the heads up on that. I have to say I'm really impressed with the speed and briskness of ML. Even on my old MacBook Pro which has gone from Leo to Snow Leo to Lion and now ML feels like it has a new lease of life.

    I'm more than happy with the £13.99 uk price.
     

Share This Page