Clear recent items in dock

Discussion in 'Mac OS X Lion (10.7)' started by rduja, Jul 22, 2011.

  1. rduja macrumors newbie

    Joined:
    Jul 22, 2011
    #1
    Since Lion, applications such as Quicktime and Preview have been caching recent items if I right-click them in the dock. Even if I clear my recent items these entries don't go away, does anyone know how do clear the "dock history"?
     
  2. me_94501, Jul 22, 2011
    Last edited: Jul 22, 2011

    me_94501 macrumors 65816

    me_94501

    Joined:
    Jan 6, 2003
    #2
    I've noticed this too. Anyone have any ideas?

    EDIT: OK, I kind of figured it out. I basically had to nuke my Dock prefs .plist, as well as the .plists for every item in my Dock that's remembering recent items. Sigh.
     
  3. Jaypiddy macrumors newbie

    Joined:
    Sep 21, 2006
    #3
    Some tips here.

    So far all I have found is to open the application that you want to clear the said dock items go under the "Open Recent" under the "File" menu and reboot the application. That will clear the "recent items" in the dock.

    There is also a way to disable the feature in Terminal for each application. The details are here on this post.
     
  4. natd1993 macrumors regular

    natd1993

    Joined:
    Jul 6, 2011
    Location:
    UK
    #4
    Clicking on the following option, and then closing the application and waiting for ten seconds seems to work for me.

    [​IMG]
     
  5. Jaypiddy macrumors newbie

    Joined:
    Sep 21, 2006
    #5
    Disable recent items in Terminal

    I found the the way that you can disable this from apps here I did the same for Quicktime and a few other apps. It works great. Do all the apps you want then re-boot.

    "Lion lists recent items with each application in the Dock (accessible via right-click) and in the Application View of Mission Control. To remove those and disable future additions, run the following commands in the Terminal. Note that to figure out the application's bundle identifier, you can open Activity Monitor, click the application in the list of processes and then click the “Sample Process” button. Then makes sure the “Display:” popup is set to “Sample Text”."

    Sampling process 66975 for 3 seconds with 1 millisecond of run time between samples
    Sampling completed, processing symbols...
    Analysis of sampling VLC (pid 66975) every 1 millisecond
    Process: VLC [66975]
    Path: /Applications/VLC.app/Contents/MacOS/VLC
    Load Address: 0x100000000
    Identifier: org.videolan.vlc
    Version: 1.1.11 (1.1.11)
    Code Type: X86-64 (Native)
    Parent Process: launchd [175]

    [...]​

    "VLC's application bundle identifier is thus org.videolan.vlc.

    Now, to disable recent item listing for VLC, you would issue the following commands in Terminal:"

    defaults write org.videolan.vlc NSRecentDocumentsLimit 0
    defaults delete org.videolan.vlc.LSSharedFileList RecentDocuments
    defaults write org.videolan.vlc.LSSharedFileList RecentDocuments -dict-add MaxAmount 0​


    _____________________
    Jaypiddy
     
  6. aquariusrick macrumors newbie

    Joined:
    Sep 7, 2009
    #6
    I found that for Preview, if you clear the recent history from the file menu and quit the application, THEN remove the application from the dock and add it back, it will get rid of the recent items that show up in the dock. No need to log out and log back in for me.
     
  7. thazsar macrumors newbie

    Joined:
    Dec 30, 2011
    #7
    Here's the steps I used to clear this info out:

    -Open the App you're targeting

    -Choose 'File' (next to the App Name)

    -Choose 'Open Recent'

    -Choose 'Clear Menu'

    -CLOSE/Quit the App

    -Reopen the App

    -Right Click on it in the Dock

    Your 'Recents/History' should now be gone!!!

    No Terminal, Commands, Rebooting, etc., etc....Just simple steps for stupid people like me!!!
     
  8. Balooba macrumors member

    Joined:
    May 27, 2003
    #8

    This at least doesn't work for QuickTime Player.
     
  9. Drew017 macrumors 65816

    Drew017

    Joined:
    May 29, 2011
    Location:
    East coast, USA
  10. andersonng macrumors newbie

    Joined:
    Sep 21, 2013
    #10
    Best Solution!

    There is an easy fix to this...(For Mountain Lion Users)
    1. Go to System Preferences
    2. General
    3. On Recent Items, Select None
    4. Voila! No More Recent Items! :D
     
  11. jufjo macrumors member

    Joined:
    Oct 6, 2008
    Location:
    Amsterdam, The Netherlands
    #11
    That doesn't work for preview.
    I still get a list of all the earlier pictures I've opened and it seems this slows it all down a bit.
     

Share This Page