Clearing Open With entries (2 hard drives)

Discussion in 'OS X Mavericks (10.9)' started by ls1dreams, Apr 5, 2014.

  1. ls1dreams macrumors 6502

    Aug 13, 2009
    Hi all,

    I added an SSD and installed Mavericks, but also kept an old HDD in my laptop with a copy of Snow Leopard so that I could dual boot back into it if I ran into compatibility issues.

    Of course, this meant I was seeing a lot of duplicate apps in spotlight and in the "open with" context menu.

    I've been able to fix most problems by doing the following:

    1. Adding my old HDD > Applications folder to the exclude list for spotlight
    2. Deleting my old file to have it rebuilt

    Now, spotlight is actually clear in mavericks which is good news. However, I'm still seeing Apple specific duplicate apps in my open with context, particularly TextEdit and Archive Utility.


    I ended up just deleting the version of TextEdit from my HDD, but can't find the Archive Utility (and others) like I did here. I'm having similar problems with VLC and other apps that still live on the HDD. Despite telling spotlight to ignore them and clearing the plist, they still show up.

    Any suggestions on how to clear up the Open With context menu? Normally I wouldn't care much but it's slow because the HDD has to spin up, sort of negating the speed of the SSD.
  2. ls1dreams thread starter macrumors 6502

    Aug 13, 2009

    Running this command worked:

    /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user
    Deleting the .plist was supposed to have the same effect, but it did not, even with a reboot. The command above instantly worked.
  3. ls1dreams thread starter macrumors 6502

    Aug 13, 2009
    Update: Apparently the above did NOT work. I'm still seeing other applications from my old HDD appear now with multiple versions (firefox, etc).

  4. Weaselboy Moderator


    Staff Member

    Jan 23, 2005
    You need to rebuild launch services to fix that. Try running this in Terminal. It is a bit different than the one you ran earlier. This command varies depending on OS X version.

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain user;killall Finder

Share This Page