Click the lock to prevent further changes not working...

Discussion in 'macOS' started by vbman213, Aug 30, 2010.

  1. vbman213 macrumors 6502

    Joined:
    Apr 13, 2010
    #1
    It is "unlocked". Every time I click it, it just stays unlocked and won't actually lock.

    For example, I can't lock it on the "Energy Saver" prefpane, but I can lock/unlock on the Accounts prefpane...
     
  2. vbman213 thread starter macrumors 6502

    Joined:
    Apr 13, 2010
    #2
  3. petzl macrumors newbie

    Joined:
    Jul 20, 2010
    #3
    Works for me, for some reason

    Same problem here.
    Bought my MBP about a month ago, and im sure it was locking at that time. Now its permanently, unchangeably unlocked in every preference (except for Accounts + Parental Controls): that is, it's unlocked and when you click on the lock, you see animation of the lock that shows an "attempt" at locking, but it doesnt lock.

    Mac OS 10.6.4
    15" Macbook Pro (2010), Core i7 2.66 GHz, 8GB 1067 Mhz DDR3


    UPDATE (5 minutes later):
    OK. Now its working. And I dont know why. But here's what I did. The places where the lock was "broken" were prefs that I access alot (like Network). But the fact that Account's lock /did/ work, made me want to check every single lock to see if there were any more exceptions. For whatever reason, I started at the bottom of Prefs, going through each one: Accts,Date/Time,ParentalCntrls-- noting that some were broken (Date/Time), one "worked" (ParentalCntls), and some had no lock at all (Speech, et al). Then, when I got to EnergySaver it worked. Or rather it was already locked. Which was strange. I unlocked it, then locked it. When I returned to the previous broken locks, like Network, they were now working. Go figure.
     
  4. G4DP macrumors 65816

    Joined:
    Mar 28, 2007
    #4
    I've had this problem on and off over the various versions of OS X.
     
  5. moonseed macrumors newbie

    Joined:
    Oct 10, 2010
    #5
    Problem with printer services

    @petzl - Thanks for the hint checking. I had the same problem with the network preferences not being locked down.

    It turns out my problem was in the Printer panel. This option is a little different as it has an option that appears on another panel (Sharing Preferences). I had a warning triangle up that said the wasn't shared. It probably had something to do with me plugging/unplugging so much as I don't have a spare USB port (I know - easily fixed!)

    By un-sharing the printer in the Printer options I was then able to lock the setting, and it cured all the others.

    Anyway - might be a unique problem with my messy setup, but it worked

    Cheers

    Simon
     
  6. jbeezz macrumors newbie

    Joined:
    Oct 26, 2010
    #6
    That worked!

    So easy! When I turned off the printer sharing I was able to lock everything else.
    Thanks!!
     

Share This Page